summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2021-04-01 20:46:22 +0200
committerSven Wegener <swegener@gentoo.org>2021-04-01 20:46:22 +0200
commitc2ab4e3a51936ffd97095cd5755fc516563ccab8 (patch)
tree498677602182df79fbdcf73044b81fb4328fcea3 /sys-kernel/cryptodev/cryptodev-1.12.ebuild
parentsys-kernel/cryptodev: Mark 1.11 stable on amd64/x86 (diff)
downloadgentoo-c2ab4e3a51936ffd97095cd5755fc516563ccab8.tar.gz
gentoo-c2ab4e3a51936ffd97095cd5755fc516563ccab8.tar.bz2
gentoo-c2ab4e3a51936ffd97095cd5755fc516563ccab8.zip
sys-kernel/cryptodev: Version bump to 1.12
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Sven Wegener <swegener@gentoo.org>
Diffstat (limited to 'sys-kernel/cryptodev/cryptodev-1.12.ebuild')
-rw-r--r--sys-kernel/cryptodev/cryptodev-1.12.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/sys-kernel/cryptodev/cryptodev-1.12.ebuild b/sys-kernel/cryptodev/cryptodev-1.12.ebuild
new file mode 100644
index 000000000000..3b2e81697ae5
--- /dev/null
+++ b/sys-kernel/cryptodev/cryptodev-1.12.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info linux-mod
+
+DESCRIPTION="device that allows access to Linux kernel cryptographic drivers"
+HOMEPAGE="http://cryptodev-linux.org/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/cryptodev-linux/cryptodev-linux.git"
+ S="${WORKDIR}/${PN}-${PV}"
+else
+ SRC_URI="https://github.com/cryptodev-linux/cryptodev-linux/archive/${PN}-linux-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+ S=${WORKDIR}/${PN}-linux-${PN}-linux-${PV}
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="examples"
+
+DEPEND="virtual/linux-sources"
+
+#test requires that the module is already loaded
+RESTRICT="test"
+
+MODULE_NAMES="cryptodev(extra:${S})"
+BUILD_PARAMS="KERNEL_DIR=\"\${KV_OUT_DIR}\""
+BUILD_TARGETS="build"
+
+pkg_pretend() {
+ use kernel_linux || die "cryptodev ebuild only support linux"
+
+ CONFIG_CHECK="~CRYPTO ~CRYPTO_AEAD"
+ if kernel_is -lt 4 8 0; then
+ CONFIG_CHECK="${CONFIG_CHECK} ~CRYPTO_BLKCIPHER"
+ else
+ CONFIG_CHECK="${CONFIG_CHECK} ~CRYPTO_SKCIPHER"
+ fi
+ check_extra_config
+}
+
+src_install() {
+ linux-mod_src_install
+
+ insinto /usr/include/crypto
+ doins crypto/cryptodev.h
+
+ if use examples ; then
+ docinto examples
+ dodoc example/*
+ fi
+}