summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2023-03-04 19:48:18 +0100
committerSven Wegener <swegener@gentoo.org>2023-03-04 19:53:17 +0100
commitf7dacf3860d28f46f5b586fa01411da030b79e4c (patch)
treeddf1f75c40b5726f2225ac7cc0fa0d96038543e0 /sys-kernel/cryptodev
parentdev-libs/libusb-compat: Stabilize 0.1.8 hppa, #899336 (diff)
downloadgentoo-f7dacf3860d28f46f5b586fa01411da030b79e4c.tar.gz
gentoo-f7dacf3860d28f46f5b586fa01411da030b79e4c.tar.bz2
gentoo-f7dacf3860d28f46f5b586fa01411da030b79e4c.zip
sys-kernel/cryptodev: drop 1.11
Signed-off-by: Sven Wegener <swegener@gentoo.org>
Diffstat (limited to 'sys-kernel/cryptodev')
-rw-r--r--sys-kernel/cryptodev/Manifest1
-rw-r--r--sys-kernel/cryptodev/cryptodev-1.11.ebuild56
2 files changed, 0 insertions, 57 deletions
diff --git a/sys-kernel/cryptodev/Manifest b/sys-kernel/cryptodev/Manifest
index 37705199474e..291074c9eb83 100644
--- a/sys-kernel/cryptodev/Manifest
+++ b/sys-kernel/cryptodev/Manifest
@@ -1,2 +1 @@
-DIST cryptodev-linux-1.11.tar.gz 56876 BLAKE2B 97cf09c515c586372b2c5bd450e445afd5f80ed8ab39002545dc550c63480469a5318214f467444618e4e1783b9ab999b550cfb16d8ded6de26671a0727d06c2 SHA512 f7b76e9a154945514e2238cd7106cb50cea8120febc79228d6a8ba2dfaf98d5f0756d970df76fd63bda4755d7e0d78331aea394c3c5c18794b7ef1a8738fddba
DIST cryptodev-linux-1.12.tar.gz 56922 BLAKE2B ec3d6585cbc15027468c0d009dfad1437286e71f90247b6b07067e1355483d9a3184cb0134ab4cfb406168b1b506fb08d4a0ab6476b71305267769a33e5ed2de SHA512 75f4f20ee7474375fd515cfd4f247f9a61739ac766525cd8fe007adfa44129d90077568d59409f577202a4d8883539b0d533dd5e060a1065b61106f68ea5e4b3
diff --git a/sys-kernel/cryptodev/cryptodev-1.11.ebuild b/sys-kernel/cryptodev/cryptodev-1.11.ebuild
deleted file mode 100644
index 89714e1aa6bd..000000000000
--- a/sys-kernel/cryptodev/cryptodev-1.11.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit linux-info linux-mod
-
-DESCRIPTION="device that allows access to Linux kernel cryptographic drivers"
-HOMEPAGE="http://cryptodev-linux.org/"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/cryptodev-linux/cryptodev-linux.git"
- S="${WORKDIR}/${PN}-${PV}"
-else
- SRC_URI="https://github.com/cryptodev-linux/cryptodev-linux/archive/${PN}-linux-${PV}.tar.gz"
- KEYWORDS="amd64 ~arm x86"
- S=${WORKDIR}/${PN}-linux-${PN}-linux-${PV}
-fi
-
-LICENSE="GPL-2+"
-SLOT="0"
-IUSE="examples"
-
-DEPEND="virtual/linux-sources"
-
-#test requires that the module is already loaded
-RESTRICT="test"
-
-MODULE_NAMES="cryptodev(extra:${S})"
-BUILD_PARAMS="KERNEL_DIR=\"\${KV_OUT_DIR}\""
-BUILD_TARGETS="build"
-
-pkg_pretend() {
- use kernel_linux || die "cryptodev ebuild only support linux"
-
- CONFIG_CHECK="~CRYPTO ~CRYPTO_AEAD"
- if kernel_is -lt 4 8 0; then
- CONFIG_CHECK="${CONFIG_CHECK} ~CRYPTO_BLKCIPHER"
- else
- CONFIG_CHECK="${CONFIG_CHECK} ~CRYPTO_SKCIPHER"
- fi
- check_extra_config
-}
-
-src_install() {
- linux-mod_src_install
-
- insinto /usr/include/crypto
- doins crypto/cryptodev.h
-
- if use examples ; then
- docinto examples
- dodoc example/*
- fi
-}