summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-05-03 15:32:32 -0400
committerMike Gilbert <floppym@gentoo.org>2017-05-29 13:28:42 -0400
commit268c6a2f07b64c01a1314f740050cc2cd1e5c8f6 (patch)
tree49cbe0ce1408b7b56eba0e80f2efbaafe228e921 /sys-kernel/dracut
parentsys-apps/iucode_tool: version bump to 2.1.2 (diff)
downloadgentoo-268c6a2f07b64c01a1314f740050cc2cd1e5c8f6.tar.gz
gentoo-268c6a2f07b64c01a1314f740050cc2cd1e5c8f6.tar.bz2
gentoo-268c6a2f07b64c01a1314f740050cc2cd1e5c8f6.zip
sys-kernel/dracut: use pkg-config at runtime for systemd
sys-apps/systemd may be moving from /usr/lib/systemd to /lib/systemd in a future release. dracut will automatically call pkg-config at run time if these paths are not in the config file. Package-Manager: Portage-2.3.5_p31, Repoman-2.3.2_p61
Diffstat (limited to 'sys-kernel/dracut')
-rw-r--r--sys-kernel/dracut/dracut-044-r3.ebuild (renamed from sys-kernel/dracut/dracut-044-r2.ebuild)23
1 files changed, 5 insertions, 18 deletions
diff --git a/sys-kernel/dracut/dracut-044-r2.ebuild b/sys-kernel/dracut/dracut-044-r3.ebuild
index 89b9eaf1e9e0..2af888711a72 100644
--- a/sys-kernel/dracut/dracut-044-r2.ebuild
+++ b/sys-kernel/dracut/dracut-044-r3.ebuild
@@ -16,7 +16,10 @@ IUSE="debug selinux systemd"
RESTRICT="test"
CDEPEND="virtual/udev
- systemd? ( >=sys-apps/systemd-199 )
+ systemd? (
+ >=sys-apps/systemd-199
+ virtual/pkgconfig
+ )
"
RDEPEND="${CDEPEND}
app-arch/cpio
@@ -95,23 +98,7 @@ src_prepare() {
sed -r -e "s|^(udevdir=).*$|\1${udevdir}|" \
-i "${S}/dracut.conf.d/gentoo.conf.example" || die
- if use systemd; then
- local systemdutildir="$(systemd_get_utildir)"
- local systemdsystemunitdir="$(systemd_get_systemunitdir)"
- local systemdsystemconfdir="$("$(tc-getPKG_CONFIG)" systemd \
- --variable=systemdsystemconfdir)"
- [[ ${systemdsystemconfdir} ]] \
- || systemdsystemconfdir=/etc/systemd/system
- einfo "Setting systemdutildir to ${systemdutildir} and ..."
- sed -e "5asystemdutildir=\"${systemdutildir}\"" \
- -i "${S}/dracut.conf.d/gentoo.conf.example" || die
- einfo "Setting systemdsystemunitdir to ${systemdsystemunitdir} and..."
- sed -e "6asystemdsystemunitdir=\"${systemdsystemunitdir}\"" \
- -i "${S}/dracut.conf.d/gentoo.conf.example" || die
- einfo "Setting systemdsystemconfdir to ${systemdsystemconfdir}..."
- sed -e "7asystemdsystemconfdir=\"${systemdsystemconfdir}\"" \
- -i "${S}/dracut.conf.d/gentoo.conf.example" || die
- else
+ if ! use systemd; then
local systemdutildir="/lib/systemd"
einfo "Setting systemdutildir for standalone udev to" \
"${systemdutildir}..."