summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-12 21:57:28 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-12 21:57:55 +0200
commita6ee476f06352eb25cd211b447b27b159fcae11f (patch)
tree4f951ab1acbe61e880f781bacc3655b5017caa34 /sys-kernel/gentoo-kernel/gentoo-kernel-5.10.32.ebuild
parentsys-kernel/gentoo-kernel-bin: Remove old (diff)
downloadgentoo-a6ee476f06352eb25cd211b447b27b159fcae11f.tar.gz
gentoo-a6ee476f06352eb25cd211b447b27b159fcae11f.tar.bz2
gentoo-a6ee476f06352eb25cd211b447b27b159fcae11f.zip
sys-kernel/gentoo-kernel: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-kernel/gentoo-kernel/gentoo-kernel-5.10.32.ebuild')
-rw-r--r--sys-kernel/gentoo-kernel/gentoo-kernel-5.10.32.ebuild90
1 files changed, 0 insertions, 90 deletions
diff --git a/sys-kernel/gentoo-kernel/gentoo-kernel-5.10.32.ebuild b/sys-kernel/gentoo-kernel/gentoo-kernel-5.10.32.ebuild
deleted file mode 100644
index 1ff510899e1b..000000000000
--- a/sys-kernel/gentoo-kernel/gentoo-kernel-5.10.32.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 2020-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit kernel-build
-
-MY_P=linux-${PV%.*}
-GENPATCHES_P=genpatches-${PV%.*}-$(( ${PV##*.} + 3 ))
-# https://koji.fedoraproject.org/koji/packageinfo?packageID=8
-CONFIG_VER=5.10.12
-CONFIG_HASH=836165dd2dff34e4f2c47ca8f9c803002c1e6530
-GENTOO_CONFIG_VER=5.10.32
-
-DESCRIPTION="Linux kernel built with Gentoo patches"
-HOMEPAGE="https://www.kernel.org/"
-SRC_URI+=" https://cdn.kernel.org/pub/linux/kernel/v$(ver_cut 1).x/${MY_P}.tar.xz
- https://dev.gentoo.org/~mpagano/dist/genpatches/${GENPATCHES_P}.base.tar.xz
- https://dev.gentoo.org/~mpagano/dist/genpatches/${GENPATCHES_P}.extras.tar.xz
- https://github.com/mgorny/gentoo-kernel-config/archive/v${GENTOO_CONFIG_VER}.tar.gz
- -> gentoo-kernel-config-${GENTOO_CONFIG_VER}.tar.gz
- amd64? (
- https://src.fedoraproject.org/rpms/kernel/raw/${CONFIG_HASH}/f/kernel-x86_64-fedora.config
- -> kernel-x86_64-fedora.config.${CONFIG_VER}
- )
- arm64? (
- https://src.fedoraproject.org/rpms/kernel/raw/${CONFIG_HASH}/f/kernel-aarch64-fedora.config
- -> kernel-aarch64-fedora.config.${CONFIG_VER}
- )
- ppc64? (
- https://src.fedoraproject.org/rpms/kernel/raw/${CONFIG_HASH}/f/kernel-ppc64le-fedora.config
- -> kernel-ppc64le-fedora.config.${CONFIG_VER}
- )
- x86? (
- https://src.fedoraproject.org/rpms/kernel/raw/${CONFIG_HASH}/f/kernel-i686-fedora.config
- -> kernel-i686-fedora.config.${CONFIG_VER}
- )"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
-IUSE="debug"
-REQUIRED_USE="arm? ( savedconfig )"
-
-RDEPEND="
- !sys-kernel/gentoo-kernel-bin:${SLOT}"
-BDEPEND="
- debug? ( dev-util/dwarves )"
-PDEPEND="
- >=virtual/dist-kernel-${PV}"
-
-src_prepare() {
- local PATCHES=(
- # meh, genpatches have no directory
- "${WORKDIR}"/*.patch
- )
- default
-
- # prepare the default config
- case ${ARCH} in
- amd64)
- cp "${DISTDIR}/kernel-x86_64-fedora.config.${CONFIG_VER}" .config || die
- ;;
- arm)
- return
- ;;
- arm64)
- cp "${DISTDIR}/kernel-aarch64-fedora.config.${CONFIG_VER}" .config || die
- ;;
- ppc64)
- cp "${DISTDIR}/kernel-ppc64le-fedora.config.${CONFIG_VER}" .config || die
- ;;
- x86)
- cp "${DISTDIR}/kernel-i686-fedora.config.${CONFIG_VER}" .config || die
- ;;
- *)
- die "Unsupported arch ${ARCH}"
- ;;
- esac
-
- echo 'CONFIG_LOCALVERSION="-gentoo-dist"' > "${T}"/version.config || die
- local merge_configs=(
- "${T}"/version.config
- "${WORKDIR}/gentoo-kernel-config-${GENTOO_CONFIG_VER}"/base.config
- )
- use debug || merge_configs+=(
- "${WORKDIR}/gentoo-kernel-config-${GENTOO_CONFIG_VER}"/no-debug.config
- )
- kernel-build_merge_configs "${merge_configs[@]}"
-}