summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2020-11-11 11:58:17 -0500
committerMike Pagano <mpagano@gentoo.org>2020-11-11 11:58:17 -0500
commit665fbafecb6936ba7df26270ac556d21d1d5c6b2 (patch)
tree49e227e19bc485a48201d35b0e25f687779a8105 /sys-kernel/gentoo-sources/gentoo-sources-4.14.206.ebuild
parentnet-vpn/openconnect: restore ~arm keyword (diff)
downloadgentoo-665fbafecb6936ba7df26270ac556d21d1d5c6b2.tar.gz
gentoo-665fbafecb6936ba7df26270ac556d21d1d5c6b2.tar.bz2
gentoo-665fbafecb6936ba7df26270ac556d21d1d5c6b2.zip
sys-kernel/gentoo-sources: Linux version bumps
Linux 4.4.243 Linux 4.9.243 Linux 4.14.206 Linux 4.19.157 Linux 5.4.77 Linux 5.9.8 Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'sys-kernel/gentoo-sources/gentoo-sources-4.14.206.ebuild')
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-4.14.206.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-4.14.206.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-4.14.206.ebuild
new file mode 100644
index 000000000000..5316d9070452
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-4.14.206.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="216"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+HOMEPAGE="https://dev.gentoo.org/~mpagano/genpatches"
+IUSE="experimental"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}