summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2020-11-18 16:03:49 -0500
committerMike Pagano <mpagano@gentoo.org>2020-11-18 16:03:55 -0500
commitdc7ab33004741d2b5109d64eb86788913772383d (patch)
tree39b89770987cf38b25c987c3d658900c0a28e017 /sys-kernel/gentoo-sources/gentoo-sources-4.14.207.ebuild
parentapp-admin/conky: Remove old conky-1.11.6-r1. (diff)
downloadgentoo-dc7ab33004741d2b5109d64eb86788913772383d.tar.gz
gentoo-dc7ab33004741d2b5109d64eb86788913772383d.tar.bz2
gentoo-dc7ab33004741d2b5109d64eb86788913772383d.zip
sys-kernel/gentoo-sources: Version bumps and genpatches updates
Linux patches: 4.4.244, 4.9.244, 4.14.207, 4.19.158, 5.4.78 and 5.9.9 5.4 only: wireguard dropped, will be re-added with working patch Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'sys-kernel/gentoo-sources/gentoo-sources-4.14.207.ebuild')
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-4.14.207.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-4.14.207.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-4.14.207.ebuild
new file mode 100644
index 000000000000..2922920abf3d
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-4.14.207.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="217"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+HOMEPAGE="https://dev.gentoo.org/~mpagano/genpatches"
+IUSE="experimental"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}