summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlice Ferrazzi <alicef@gentoo.org>2021-02-10 22:59:08 +0900
committerAlice Ferrazzi <alicef@gentoo.org>2021-02-10 23:00:55 +0900
commitf4abf4bb0d3bc8bccac0e9674fae6b2bbb8df810 (patch)
tree1f2af1e86797c41bcd7685890331ba33231eee17 /sys-kernel/gentoo-sources/gentoo-sources-4.19.175.ebuild
parentgui-apps/wcm: inherit xdg for xdg_icon_cache_update() (diff)
downloadgentoo-f4abf4bb0d3bc8bccac0e9674fae6b2bbb8df810.tar.gz
gentoo-f4abf4bb0d3bc8bccac0e9674fae6b2bbb8df810.tar.bz2
gentoo-f4abf4bb0d3bc8bccac0e9674fae6b2bbb8df810.zip
sys-kernel/gentoo-sources: Linux patch updates
Linux 4.14.221 Linux 4.19.175 Linux 4.4.257 Linux 4.9.257 Linux 5.10.15 Linux 5.4.97 Package-Manager: Portage-2.3.89, Repoman-2.3.23 Signed-off-by: Alice Ferrazzi <alicef@gentoo.org>
Diffstat (limited to 'sys-kernel/gentoo-sources/gentoo-sources-4.19.175.ebuild')
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-4.19.175.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-4.19.175.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-4.19.175.ebuild
new file mode 100644
index 000000000000..e9acca38171e
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-4.19.175.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="174"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+HOMEPAGE="https://dev.gentoo.org/~mpagano/genpatches"
+IUSE="experimental"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}