summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-12-01 15:17:00 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-12-01 15:17:00 +0100
commit8bf3a5ed4bb35c2477b8a9d859b327ad46d2be1d (patch)
treef1a528a1b032026102f317878910e732e138c4b8 /sys-kernel/gentoo-sources/gentoo-sources-4.19.87.ebuild
parentsys-kernel/gentoo-sources: Linux patch 4.14.157 (diff)
downloadgentoo-8bf3a5ed4bb35c2477b8a9d859b327ad46d2be1d.tar.gz
gentoo-8bf3a5ed4bb35c2477b8a9d859b327ad46d2be1d.tar.bz2
gentoo-8bf3a5ed4bb35c2477b8a9d859b327ad46d2be1d.zip
sys-kernel/gentoo-sources: Linux patch 4.19.87
Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'sys-kernel/gentoo-sources/gentoo-sources-4.19.87.ebuild')
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-4.19.87.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-4.19.87.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-4.19.87.ebuild
new file mode 100644
index 000000000000..663045668428
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-4.19.87.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="86"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+HOMEPAGE="https://dev.gentoo.org/~mpagano/genpatches"
+IUSE="experimental"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}