summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2015-12-15 07:07:44 -0500
committerMike Pagano <mpagano@gentoo.org>2015-12-15 07:07:44 -0500
commit7e88e5f8cbd5c68d867b722ff1a877b70f86059a (patch)
tree43559404e2163144160b1224f6945c9e60a0b122 /sys-kernel/gentoo-sources/gentoo-sources-4.3.3.ebuild
parentsys-kernel/gentoo-sources: Linux patch 4.2.8 (diff)
downloadgentoo-7e88e5f8cbd5c68d867b722ff1a877b70f86059a.tar.gz
gentoo-7e88e5f8cbd5c68d867b722ff1a877b70f86059a.tar.bz2
gentoo-7e88e5f8cbd5c68d867b722ff1a877b70f86059a.zip
sys-kernel/gentoo-sources: Linux patch 4.3.3
Package-Manager: portage-2.2.24
Diffstat (limited to 'sys-kernel/gentoo-sources/gentoo-sources-4.3.3.ebuild')
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-4.3.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-4.3.3.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-4.3.3.ebuild
new file mode 100644
index 000000000000..1c3e505af34b
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-4.3.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="4"
+K_DEBLOB_AVAILABLE="0"
+K_KDBUS_AVAILABLE="0"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 -hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+HOMEPAGE="https://dev.gentoo.org/~mpagano/genpatches"
+IUSE="experimental"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}