summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlice Ferrazzi <alicef@gentoo.org>2016-10-28 20:13:13 +0100
committerAlice Ferrazzi <alicef@gentoo.org>2016-10-28 20:13:56 +0100
commit7d7b93a402968723091e8f73e91960a57c3f37ea (patch)
treec8510bf0f3e9103ab67197e7fd9c26435123f380 /sys-kernel/gentoo-sources/gentoo-sources-4.4.28.ebuild
parentlxqt-base/lxqt-notificationd: Version bump to 0.11.0 (diff)
downloadgentoo-7d7b93a402968723091e8f73e91960a57c3f37ea.tar.gz
gentoo-7d7b93a402968723091e8f73e91960a57c3f37ea.tar.bz2
gentoo-7d7b93a402968723091e8f73e91960a57c3f37ea.zip
sys-kernel/gentoo-sources: Linux patch 4.4.28
Package-Manager: portage-2.3.0
Diffstat (limited to 'sys-kernel/gentoo-sources/gentoo-sources-4.4.28.ebuild')
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-4.4.28.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-4.4.28.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-4.4.28.ebuild
new file mode 100644
index 000000000000..2dd8eb415373
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-4.4.28.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="30"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 -hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+HOMEPAGE="https://dev.gentoo.org/~mpagano/genpatches"
+IUSE="experimental"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}