summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2020-10-17 08:37:50 -0400
committerMike Pagano <mpagano@gentoo.org>2020-10-17 08:37:50 -0400
commitcaeba42eb3968f5c264969f535955b30db870ad3 (patch)
tree5e18135d7be8708377b8d1723804f3363ccea692 /sys-kernel/gentoo-sources/gentoo-sources-5.8.16.ebuild
parentdev-ml/ocamlgraph: DeprecatedInsinto (diff)
downloadgentoo-caeba42eb3968f5c264969f535955b30db870ad3.tar.gz
gentoo-caeba42eb3968f5c264969f535955b30db870ad3.tar.bz2
gentoo-caeba42eb3968f5c264969f535955b30db870ad3.zip
sys-kernel/gentoo-sources: Linux patches and genpatches
Linux patch 5.9.1 Linux patch 5.8.16 Linux patch 5.4.72 Linux patch 4.19.152 Linux patch 4.14.202 Linux patch 4.9.240 Linux patch 4.4.240 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'sys-kernel/gentoo-sources/gentoo-sources-5.8.16.ebuild')
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-5.8.16.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-5.8.16.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-5.8.16.ebuild
new file mode 100644
index 000000000000..a6eed9ecf7f3
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-5.8.16.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="19"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+HOMEPAGE="https://dev.gentoo.org/~mpagano/genpatches"
+IUSE="experimental"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}