summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2016-04-25 08:01:12 -0400
committerMike Pagano <mpagano@gentoo.org>2016-04-25 08:01:12 -0400
commit0e1abbe0bffa83f791195d744aeaef697a4c41bd (patch)
tree16995f9f4bc2d72d60896f2e55589b1915fd7629 /sys-kernel/git-sources/git-sources-4.6_rc5.ebuild
parentmedia-plugins/kodi-pvr-hts: version bump (diff)
downloadgentoo-0e1abbe0bffa83f791195d744aeaef697a4c41bd.tar.gz
gentoo-0e1abbe0bffa83f791195d744aeaef697a4c41bd.tar.bz2
gentoo-0e1abbe0bffa83f791195d744aeaef697a4c41bd.zip
sys-kernel/git-sources: Linux patch 4.6_rc5
Package-Manager: portage-2.2.28
Diffstat (limited to 'sys-kernel/git-sources/git-sources-4.6_rc5.ebuild')
-rw-r--r--sys-kernel/git-sources/git-sources-4.6_rc5.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/git-sources-4.6_rc5.ebuild b/sys-kernel/git-sources/git-sources-4.6_rc5.ebuild
new file mode 100644
index 000000000000..af024fbe50b0
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-4.6_rc5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="yes"
+K_BASE_VER="4.5"
+K_EXP_GENPATCHES_NOUSE="1"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.4"
+
+pkg_postinst() {
+ postinst_sources
+}