summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2021-01-25 08:38:39 +0100
committerAgostino Sarubbo <ago@gentoo.org>2021-01-25 08:38:39 +0100
commita6bd3e8a0c130f0813c124e21c54a2b5b98ddb0d (patch)
tree7f15c69b905a47e912901d74d5b5f0a96af85243 /sys-kernel/git-sources/git-sources-5.11_rc5.ebuild
parentmail-client/mutt-2.0.2: cleanup vulnerable version (diff)
downloadgentoo-a6bd3e8a0c130f0813c124e21c54a2b5b98ddb0d.tar.gz
gentoo-a6bd3e8a0c130f0813c124e21c54a2b5b98ddb0d.tar.bz2
gentoo-a6bd3e8a0c130f0813c124e21c54a2b5b98ddb0d.zip
sys-kernel/git-sources: Automated version bump to 5.11_rc5.
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Diffstat (limited to 'sys-kernel/git-sources/git-sources-5.11_rc5.ebuild')
-rw-r--r--sys-kernel/git-sources/git-sources-5.11_rc5.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/git-sources-5.11_rc5.ebuild b/sys-kernel/git-sources/git-sources-5.11_rc5.ebuild
new file mode 100644
index 000000000000..d3797acbcee8
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-5.11_rc5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="5.10"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.5"
+
+pkg_postinst() {
+ postinst_sources
+}