summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2021-03-14 18:09:28 -0400
committerMike Pagano <mpagano@gentoo.org>2021-03-14 18:09:28 -0400
commit46584b236e4a11835cf972d22dcfe49f88f0ab10 (patch)
tree5b1ad6f94104bed2809c7491ea626a2878010d31 /sys-kernel/git-sources/git-sources-5.12_rc3.ebuild
parentdev-ml/ocaml-ctypes: Stabilize 0.17.1 arm, #775782 (diff)
downloadgentoo-46584b236e4a11835cf972d22dcfe49f88f0ab10.tar.gz
gentoo-46584b236e4a11835cf972d22dcfe49f88f0ab10.tar.bz2
gentoo-46584b236e4a11835cf972d22dcfe49f88f0ab10.zip
sys-kernel/git-sources: Linux patch 5.12-rc3
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'sys-kernel/git-sources/git-sources-5.12_rc3.ebuild')
-rw-r--r--sys-kernel/git-sources/git-sources-5.12_rc3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/git-sources-5.12_rc3.ebuild b/sys-kernel/git-sources/git-sources-5.12_rc3.ebuild
new file mode 100644
index 000000000000..841923d20fb6
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-5.12_rc3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="5.11"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.5"
+
+pkg_postinst() {
+ postinst_sources
+}