summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2022-09-11 17:36:22 -0400
committerMike Pagano <mpagano@gentoo.org>2022-09-11 17:36:22 -0400
commit154a6b261ea0028abb15c60bdd3f89bae08ca2d1 (patch)
treec1418260b1ac562f9991d7e870816a354694ab31 /sys-kernel/git-sources
parentprofiles/arch/sparc: add dev-lang/rust[system-bootstrap] to p.u.stable.force too (diff)
downloadgentoo-154a6b261ea0028abb15c60bdd3f89bae08ca2d1.tar.gz
gentoo-154a6b261ea0028abb15c60bdd3f89bae08ca2d1.tar.bz2
gentoo-154a6b261ea0028abb15c60bdd3f89bae08ca2d1.zip
sys-kernel/git-sources: add 6.0_rc5
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'sys-kernel/git-sources')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-6.0_rc5.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index 4e7336accdc5..413b94c34710 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -3,3 +3,4 @@ DIST patch-6.0-rc1.patch 107038239 BLAKE2B bea392cf4596fe326b58c08c20918bfe34d9b
DIST patch-6.0-rc2.patch 107549416 BLAKE2B a4fefa99fab946258b1fc4c2cd3e8cd92de4047e53f6695ceaebc67d62d11df267dbc34d8f5e3ed1517dc98fb4cd4d8c8d0ce5cefe9b211b3ce63a6efe60f5c0 SHA512 cc950717e1ccc7d3e4b7222db2f368e3a7377bcf7c4c1999b6e921ebfb5c71547747c2dd2465ce4c1880fe966108b1b0474d76d6ea014bfe70493245c644d631
DIST patch-6.0-rc3.patch 107861796 BLAKE2B 201851c3bb54d6af7a481b0b88067d738e0bb8c71b4aa422914d20c70a09724a35e0a770dad95143c7718496c30087d912328d8780b3ffa6fe8579526742a547 SHA512 f27886b6ccafc2b7dda42f997c960ff2cacdeaf653dbdbc7148cf8286599461c7c716dc0f57b7ead0c609791fa70ba94ee4a7a41e047910bf753ffe921cbdbd8
DIST patch-6.0-rc4.patch 108161851 BLAKE2B 095c03da992f3b2ea26aaea3a10fa4efded546bb409e7580f689cd312dce77378397525776b9b138c158dbf59cd3061db99f48919afb003f3766965050b381ce SHA512 1386f9ac2fdfc5fbf07e524ed573be4f0df00fd2c0add97289e3d98ce36441339f81bfd3106dabf79898de50b363eff2f7cc88d03746f578b299fa13a0000438
+DIST patch-6.0-rc5.patch 108427807 BLAKE2B 44f625c28f292d3ba2c43ebc6e06059c3874f0a4a1a645bd4ebda483fcc52eb4fc5dc166bd5bfc4dce5cac809901d53c9235bb7fc8003db73bbe2307b41057c0 SHA512 f5e8a8c74738b996633748eb8c84eaca3a1635335de4528a6f5c5446107c96b55e3b89867bd05207818e67fa711ed841dbd459b2b76d24f783f4b160404977a4
diff --git a/sys-kernel/git-sources/git-sources-6.0_rc5.ebuild b/sys-kernel/git-sources/git-sources-6.0_rc5.ebuild
new file mode 100644
index 000000000000..6789923d7615
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-6.0_rc5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="5.19"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+K_NODRYRUN="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.6-r4"
+
+pkg_postinst() {
+ postinst_sources
+}