summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2020-09-27 19:29:25 -0400
committerMike Pagano <mpagano@gentoo.org>2020-09-27 19:29:25 -0400
commit35101426890f72636118c5e73faa80a43e662762 (patch)
treee521acf1088150f8d4e5640916b553a286909be4 /sys-kernel/git-sources
parentdev-embedded/libjaylink: Add BDEPEND on virtual/pkgconfig (diff)
downloadgentoo-35101426890f72636118c5e73faa80a43e662762.tar.gz
gentoo-35101426890f72636118c5e73faa80a43e662762.tar.bz2
gentoo-35101426890f72636118c5e73faa80a43e662762.zip
sys-kernel/git-sources: Linux patch 5.9-rc7
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'sys-kernel/git-sources')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-5.9_rc7.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index 449842d5429a..6fb895757186 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -5,3 +5,4 @@ DIST patch-5.9-rc3.patch 63570996 BLAKE2B 7bd2b596298f5cee0baf480544592d0964b473
DIST patch-5.9-rc4.patch 63952223 BLAKE2B 13121098e6d93ed02b21e9dcef1fd2dc806b0b11958261e05feee2b2b3f946833fe266b1016c84fee7554278d64158f87da91779313b79fbf8407b2e8d2e92ca SHA512 0b167737a08e413a1fb62a7656e7130029e997bbc733924b9e523cea95945126f1da6e7c90a2c5fd97f9621a4c4ddb27e5e462ac4c4b227e4f0492096c0f1201
DIST patch-5.9-rc5.patch 64122375 BLAKE2B 0f7d66eb7a8bb70fba3068fb77d3a21349e775f4c8f97c4f971fec8c3414d463450928a8c4cc30d26e06d9a7ca8796714631fe7a084c71cf89c6942ffe24503c SHA512 414d7c0d1c42487de01398657e7e8f8801258ad0cbcd5087af6aa59372c04420379fc5a639005a07ef0dce4e7a8cede3c389c3a409ad4647d48cad6a1123ad6d
DIST patch-5.9-rc6.patch 64271496 BLAKE2B 63a7c1054eb11e9d0cf4829e7d8033d501fa7f7495327c4b424a96b338c1e49fbeae6447cd1134c6632c978e4b65dd4f477dbedb39cc09892f044ce79ae38ca1 SHA512 ea3247d5e860898e4254ac32a2583c926c3179dadf6f9132829c636870c733b21fa09dd4ffca6d9522ed486bed7265c47f01bb435f47bbea34f440dd7989501e
+DIST patch-5.9-rc7.patch 64541010 BLAKE2B 550872db5861c55eb01e801bf1ff7f9aeea65d06940b0662b455f73267dd9df4edec6c01523b583045c448f2de59886bb497dc8d39d69d1a9a9877f5bd9850b6 SHA512 945be50ee1a5529ad49ddc5613a3603f1d85ee53a68032a0f75ec2ac694100e2ccdea5af97ee72b2f73cde41c98a284754e846f5668a8c091fe51f77b3cfab3c
diff --git a/sys-kernel/git-sources/git-sources-5.9_rc7.ebuild b/sys-kernel/git-sources/git-sources-5.9_rc7.ebuild
new file mode 100644
index 000000000000..c239fcfa16c8
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-5.9_rc7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="5.8"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.5"
+
+pkg_postinst() {
+ postinst_sources
+}