summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2023-01-08 13:34:05 -0500
committerMike Pagano <mpagano@gentoo.org>2023-01-08 13:34:05 -0500
commitdd2a0a47ffce617b9e99deecfa690c769260893b (patch)
tree1d715d0aac6b1f043e205856516ebc8fb149d6f0 /sys-kernel/git-sources
parentdev-java/asm: Stabilize 9.4 arm64, #890236 (diff)
downloadgentoo-dd2a0a47ffce617b9e99deecfa690c769260893b.tar.gz
gentoo-dd2a0a47ffce617b9e99deecfa690c769260893b.tar.bz2
gentoo-dd2a0a47ffce617b9e99deecfa690c769260893b.zip
sys-kernel/git-sources: add 6.2_rc3
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'sys-kernel/git-sources')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-6.2_rc3.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index 82b009a989e0..6a1e445ed679 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -1,3 +1,4 @@
DIST linux-6.1.tar.xz 134728520 BLAKE2B ae60257860b2bd1bd708d183f0443afc60ebbd2b3d535c45e44c2e541bd0928530a3b62de6385dd4e4726ebbedcc0a871d4f3ffb4105b9f1f6d8ed7467f5688e SHA512 6ed2a73c2699d0810e54753715635736fc370288ad5ce95c594f2379959b0e418665cd71bc512a0273fe226fe90074d8b10d14c209080a6466498417a4fdda68
DIST patch-6.2-rc1.patch 61917436 BLAKE2B 038ccb5a750e55c926f223456acf32b06f38e01c1449fbd102d685202342ed774672927688cef83c19558bcb1b45919a85c34b3088ac81df6c81e569e4ed0ac2 SHA512 3a5fd0288c20bfb234e5f62102ebf9caa4addbe91e39c1a5882cbe68b32f2e6bfda1e91247526f5e0b3e18400906a44112c29f21777f838860a52b520eb7dc54
DIST patch-6.2-rc2.patch 62009581 BLAKE2B b17cc02211a6c6c3f97eb8dd8896c572ea1dcef404c08c374aa21cb1d21d6c51bab37207454d2af63ae99e5c97fcd11e44ff243f82b57183a03a80131a838fc3 SHA512 047856bb07a371579a520a62d91f6fce78537da1826ea7ea3e39504470b47968c039037684e5b88918f48de1a22f1b6aa8ebbe7ab22f52ab4f0440255970c5a2
+DIST patch-6.2-rc3.patch 62224587 BLAKE2B e873338f80f379aceb3444e3e397014c1b91f1cb012e3080063e1d33c7339d84da25402fb40711f9c496becbedbd73935226f97061f8747e51022c3400f57c66 SHA512 a1a86364b57a03b3122dd54a012ad6de65696f21140d2958700668c9a63c3cc052ac2670177e188384961310568faabe87c351608efdf7dde69d4bdb6248c3f2
diff --git a/sys-kernel/git-sources/git-sources-6.2_rc3.ebuild b/sys-kernel/git-sources/git-sources-6.2_rc3.ebuild
new file mode 100644
index 000000000000..3361401fba57
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-6.2_rc3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="6.1"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+K_NODRYRUN="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.6-r4"
+
+pkg_postinst() {
+ postinst_sources
+}