summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2019-11-03 18:27:40 -0500
committerMike Pagano <mpagano@gentoo.org>2019-11-03 18:27:51 -0500
commitec1ddfe403d8fdab4481ff6a00641fc6070fb018 (patch)
treeea1e6e3797e8b4b2be4d08ed71e90073c7e13631 /sys-kernel/git-sources
parentdev-python/python-stdnum: Restrict test (diff)
downloadgentoo-ec1ddfe403d8fdab4481ff6a00641fc6070fb018.tar.gz
gentoo-ec1ddfe403d8fdab4481ff6a00641fc6070fb018.tar.bz2
gentoo-ec1ddfe403d8fdab4481ff6a00641fc6070fb018.zip
sys-kernel/git-sources: Linux patch 5.4-rc6
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'sys-kernel/git-sources')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-5.4_rc6.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index 93c40c455f9b..5cae3f6c2a79 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -4,3 +4,4 @@ DIST patch-5.4-rc2.patch 64354864 BLAKE2B 864d97e1ed5986448fdb1bc8782e1be236b702
DIST patch-5.4-rc3.patch 64816978 BLAKE2B 792d0a5149c03ee81c82a1a59b54f64339c5fada49a81115e303deda82a07b3f5f6f5a38205ad01490fc24e7bf7d4d3937e4dd597b6d367e9ddc5f81728a5f27 SHA512 a370c3093d8bfcb6fc6bacaca9e5eff44c32d14f5b49c534298407f1e2625802f93afd407e3f2c002f86adbb64ef3a97a7d29ced09b79600238029e0375c7b4b
DIST patch-5.4-rc4.patch 65188215 BLAKE2B b21830779c7e941ba794fe574a705b292615a83fc59632a6d6bb40cb30dbb51af38879c65e0e8c7cbe8e2b3393f273866b737b86ae79c327f369e6289e082103 SHA512 7f7efd9b0a26c55974e6ce7f979ee1eabce8e9bdf4f5a2392d9c61e8a9a1f00045ddf683c1574e0fb6849dbca8fc79397e7dc2fbeac3d72b68162c8e1f4d0f11
DIST patch-5.4-rc5.patch 65413587 BLAKE2B c96d21d762e5cf348bc270459c360ff76cdaa1027a05c55b13db64de1479cf3017b97231450f96bf4e40002b246c9eaf88b0f028d5487298fbfa80c7d7363ed0 SHA512 457827d6877dd8c071437d3def99d23d3c65091cda89908f093b77fb59e3ae22e601b62f6156aa27a484415ce2e6084fee22709ab460ca33a79be5ea038ea105
+DIST patch-5.4-rc6.patch 65835147 BLAKE2B e63b88e78069da1dfdb543855e819fafd2c7c694f0d6d3592d289289fed374291a7085fea48aa662f67a294a2b62cba49de74820d1c96123c6f69cc5e1d8fb2f SHA512 59f724e2afd61aeb177a437adb3f8013a8a8bca360ca63a71cb3dc10724ef809ee8ed21c780045223f69be25ab81e89a0d8c18ec531b6ae63eb2b3597d7c2b60
diff --git a/sys-kernel/git-sources/git-sources-5.4_rc6.ebuild b/sys-kernel/git-sources/git-sources-5.4_rc6.ebuild
new file mode 100644
index 000000000000..7f3937ff7927
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-5.4_rc6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="5.3"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.5"
+
+pkg_postinst() {
+ postinst_sources
+}