summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2017-05-29 14:16:48 +0200
committerAgostino Sarubbo <ago@gentoo.org>2017-05-29 14:16:48 +0200
commitf0f43321dc79ad7ad34375c77332d95fd684d503 (patch)
tree7cbbe1f4a588556e51db93bdea305e62d072c5ca /sys-kernel/git-sources
parentsys-kernel/vanilla-sources: Automated version bump to 4.1.40 - remove old. (diff)
downloadgentoo-f0f43321dc79ad7ad34375c77332d95fd684d503.tar.gz
gentoo-f0f43321dc79ad7ad34375c77332d95fd684d503.tar.bz2
gentoo-f0f43321dc79ad7ad34375c77332d95fd684d503.zip
sys-kernel/git-sources: Automated version bump to 4.12_rc3.
Package-Manager: Portage-2.3.5, Repoman-2.3.1 Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Diffstat (limited to 'sys-kernel/git-sources')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-4.12_rc3.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index dd570d00173f..c8e627604d9d 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -1,3 +1,4 @@
DIST linux-4.11.tar.xz 95447768 SHA256 b67ecafd0a42b3383bf4d82f0850cbff92a7e72a215a6d02f42ddbafcf42a7d6 SHA512 6610eed97ffb7207c71771198c36179b8244ace7222bebb109507720e26c5f17d918079a56d5febdd8605844d67fb2df0ebe910fa2f2f53690daf6e2a8ad09c3 WHIRLPOOL f577b7c5c209cb8dfef2f1d56d77314fbd53323743a34b900e2559ab0049b7c2d6262bda136dd3d005bc0527788106e0484e46558448a8720dac389a969e5886
DIST patch-4.12-rc1.patch 89253799 SHA256 516dc994c0d1872f27bb83e07f6d2dd506594ae0bc88e5a11e5637dc2b446f2f SHA512 d58b40b44923ffd8d51c58c4ea2c5de75b766888bd65147c308441e77b56deda8476f211edcadc2eb2e4959b35d2a27b4edcb3bd3261787a9f1d0ae491e92200 WHIRLPOOL 0e388627277a97af05bf3f3fff09c03bac2ec60bdc56feb0cd2664aa73c6ef150be50cbaba6fa866911ea3e1074b7c55b6dfb906684b6bb4b1dcd8028887cb1e
DIST patch-4.12-rc2.patch 89563541 SHA256 76e32580cc6fa58e016453856267d61e2b2c464d3bf6808f26c32de9729023fa SHA512 f3ada61c34ff3c39e4bc76fb62a0bfa23e21f4a6f40caa8b51085da57c1938878a070856a7bd2f0abaeb353fbc86eb5e07da466edcabfb5d34d7edf5f4b00655 WHIRLPOOL b356e682df8ec325137b09b9f935a715e0a0d5eb3a6b0e42e3ab51d1702044c4741309cc861767a53a9b0eb79663146b58b2414e910a103d595b6232ff8c4cac
+DIST patch-4.12-rc3.patch 89897831 SHA256 d7cd828bdeb0d8b2a584ae87449ab88df8f4344d04add02a4e1ada8067ddbd34 SHA512 82ada025b3b28ecd9effccc4c414c4e6f1dd24c06f4f62eced557e30ccc41c1575927129b6c7dd956ad99d8561522ed5dc3255037b6c3fcedef88b9aa11ebaa4 WHIRLPOOL a6af83a4918a60c2b0fc77617c374751a1fc5bf37d5a10abcffc07bf9686a3904d49546b28a33481c8f8aa8ab0cd9fb410f8ce709049223b39f3569f9ddec6fb
diff --git a/sys-kernel/git-sources/git-sources-4.12_rc3.ebuild b/sys-kernel/git-sources/git-sources-4.12_rc3.ebuild
new file mode 100644
index 000000000000..77ebfa1611cb
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-4.12_rc3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="4.11"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.4"
+
+pkg_postinst() {
+ postinst_sources
+}