summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2018-11-25 18:32:29 -0500
committerMike Pagano <mpagano@gentoo.org>2018-11-25 18:32:38 -0500
commitfbb33b61e1b25a1f04af2ae26d23ac2def8f4c01 (patch)
treebe0403b5d5f851af7ca59cfa73a2c09ad0bcc3d5 /sys-kernel/git-sources
parentmedia-sound/supercollider: Fix usex call (diff)
downloadgentoo-fbb33b61e1b25a1f04af2ae26d23ac2def8f4c01.tar.gz
gentoo-fbb33b61e1b25a1f04af2ae26d23ac2def8f4c01.tar.bz2
gentoo-fbb33b61e1b25a1f04af2ae26d23ac2def8f4c01.zip
sys-kernel/git-sources: Linux patch 4.20-rc4
Signed-off-by: Mike Pagano <mpagano@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'sys-kernel/git-sources')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-4.20_rc4.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index 222c251c8a3d..05a14144b490 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -2,3 +2,4 @@ DIST linux-4.19.tar.xz 103117552 BLAKE2B 1dbf16cf410867412d17568fe42bc1e90c03418
DIST patch-4.20-rc1.patch 48053133 BLAKE2B 21b563b992bedb9d9eb0011804cc9d6c862f7e55194c02679e3ec540aa0913ecdfc2dd9769a34b8e2980427fc0e3116743b17516a1aa7607a984dd7ee4bca10e SHA512 04bd50386208ff7f3aecf50c79702368a75aac1d356cc5020d379abd80aff821afd501d05e6fab42cca48bba0593f71442534d9fbc119f1cf0dd056999f78c22
DIST patch-4.20-rc2.patch 48404086 BLAKE2B 12646687c66d6374aaa5207770e39386b07bc0a4d445cb92a2cf563a326e49d2d5cf0eeaa805557aac1526b636762be97887a0b466cfcd9e71b02d38b9dd97b1 SHA512 f41189be7659962e451eedd7e057420fe7744ca82608260b2212bf97bcc2e59fd143c3c261e1f1a35e4fff80e500c2b436a46b50c209c7cdceb5ef5cc9fa628f
DIST patch-4.20-rc3.patch 48529229 BLAKE2B 2038039535eaf2e665b37b97d445f04c059a0111ec4d2da706b101f7a8b1dde00ea754f31266431c7bbe5d7a6fc5143b44486fc636c7b2e58181a88308838cd2 SHA512 4db0be60f09f19ae0cfa141bea43fd361bd307edafdd92d8c3418e3944120b01204b4e683c723f583318849336f4fe465309f9e854748b2c06c7330dfcb5a327
+DIST patch-4.20-rc4.patch 48770023 BLAKE2B 42f4c2d9e021752708587f582b4b72bfc2d01876e366ca1c8e143e0eb1f7d453408e74246162cbdf0ca8482821e152d51a0ead50154d7d902b6953ce4ee975b3 SHA512 2b16a9deb7e5e8b80bf652e42672f4e60e81b2f6cab6928e8bed15bfd07233970269a6831621827b43b5340f132a25f161d50f503aa80f37014e901437fdea7c
diff --git a/sys-kernel/git-sources/git-sources-4.20_rc4.ebuild b/sys-kernel/git-sources/git-sources-4.20_rc4.ebuild
new file mode 100644
index 000000000000..54e27e6f6a7e
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-4.20_rc4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="4.19"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.5"
+
+pkg_postinst() {
+ postinst_sources
+}