summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2021-03-19 08:22:55 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-03-19 08:22:55 +0200
commit8d299ea2093a4591488f18bb6117bf2cb5e6b094 (patch)
treefb08b0003e21536cb1220056a4a4df54d68d9038 /sys-kernel/pf-sources
parentmedia-gfx/chafa: stabilize 1.6.0 on x86 (diff)
downloadgentoo-8d299ea2093a4591488f18bb6117bf2cb5e6b094.tar.gz
gentoo-8d299ea2093a4591488f18bb6117bf2cb5e6b094.tar.bz2
gentoo-8d299ea2093a4591488f18bb6117bf2cb5e6b094.zip
sys-kernel/pf-sources: bump to 5.11-pf4
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-kernel/pf-sources')
-rw-r--r--sys-kernel/pf-sources/Manifest1
-rw-r--r--sys-kernel/pf-sources/pf-sources-5.11_p4.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/sys-kernel/pf-sources/Manifest b/sys-kernel/pf-sources/Manifest
index 878ffbf25f45..3669498231b8 100644
--- a/sys-kernel/pf-sources/Manifest
+++ b/sys-kernel/pf-sources/Manifest
@@ -11,4 +11,5 @@ DIST pf-sources-5.10_p12.patch 5244822 BLAKE2B ca004890e20a07864e858bf1834265f12
DIST pf-sources-5.11_p1.patch 2710131 BLAKE2B 67a3528d1c59f24af9f09bc669e736d41394041874e07ebaa68bba8393d98b6094f3c733f1f395cb0a816f418702934d7ac828fceabebcec187526ca378929f4 SHA512 0bc79a5eb093c0b072826098b78894d59bab2bb8107221c9727c4aebb839b2e4d066c2f4918614bfbf4e3af210a6d1852189303f9ebf338f2e5038f166d4dfb0
DIST pf-sources-5.11_p2.patch 2720760 BLAKE2B db2ccb4449d6ed2d545c15ef82b99d581e462908ab2290b62119c09da93a7cf202e3a1792a1bf3afb6ae98f4c9f8ea34ef7ad7056206f3eac7daa8a7a9559f4a SHA512 1ab4748cac5a8a210a48543606c2c3e30e4528c819b4e7d7e29d992d4f9b14ae6e7219d7d96d090fc887d72887735e52dad9a8d396d775c8c32b80b01532a9ea
DIST pf-sources-5.11_p3.patch 3932843 BLAKE2B 655d68a6cced89aeab7b71cb67d0469567201766f378371e0e6c933fb4ac48317e27c5a148dc70117550c4f09c2b8d4c7690f5f0d88754d80fe8ca9ab9bc2415 SHA512 3b1444baa42a737166c1ce7b40d616123b2df197f9f6fc3041fded977f760627603656fbb6f41c12ad008ec724d96ae81664bbaedda4f3759aec50cb5820776b
+DIST pf-sources-5.11_p4.patch 4443076 BLAKE2B 294d1eb3ec09de6c5d6011913a8d831185a424a85e3bc6d245bd3ef4fe6b50d8e2b64decf398c153435de0b24c2417a7076ae854424201ce61cfdbbdedf4565f SHA512 3a14d63039e1a3701493d17b164364ef3c9167333e16aa8202b2967eebfaab3bd0c233b1e09af44a190a86a1b5599ee339f9ae06298c77404e7f99c6f9f14df7
DIST pf-sources-5.9_p7.patch 3027972 BLAKE2B 9247ea63b30f9d42d79303b73a900d468a71e703333932f7f15ae697cdba52c46358297023e037226c219fad5df912fb5d21e6f4b7190556ca799fa84924480e SHA512 c69e14f59bf98944b3329c65b7e2c271d74a756bc8c890130bf3cc68b4b96d31f1c33c4edb128580fcaefeb6e42dd04b1eb3d7f071b2d58bc764d26322bda8cd
diff --git a/sys-kernel/pf-sources/pf-sources-5.11_p4.ebuild b/sys-kernel/pf-sources/pf-sources-5.11_p4.ebuild
new file mode 100644
index 000000000000..223e79a03a51
--- /dev/null
+++ b/sys-kernel/pf-sources/pf-sources-5.11_p4.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# Define what default functions to run
+ETYPE="sources"
+
+# No 'experimental' USE flag provided, but we still want to use genpatches
+K_EXP_GENPATCHES_NOUSE="1"
+
+# Just get basic genpatches, -pf patch set already includes vanilla-linux updates
+K_GENPATCHES_VER="1"
+
+# -pf already sets EXTRAVERSION to kernel Makefile
+K_NOSETEXTRAVERSION="1"
+
+# Not supported by the Gentoo security team
+K_SECURITY_UNSUPPORTED="1"
+
+# We want the very basic patches from gentoo-sources, experimental patch is
+# already included in pf-sources
+K_WANT_GENPATCHES="base extras"
+
+inherit kernel-2 optfeature
+detect_version
+
+DESCRIPTION="Linux kernel fork that includes the pf-kernel patchset and Gentoo's genpatches"
+HOMEPAGE="https://gitlab.com/post-factum/pf-kernel/-/wikis/README
+ https://dev.gentoo.org/~mpagano/genpatches/"
+SRC_URI="${KERNEL_URI}
+ https://github.com/pfactum/pf-kernel/compare/v${PV/_p*/}...v${PV/_p*/}-pf${PV/*_p/}.diff -> ${P}.patch
+ https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${PV/_p*/}-${K_GENPATCHES_VER}.base.tar.xz
+ https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${PV/_p*/}-${K_GENPATCHES_VER}.extras.tar.xz"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+S="${WORKDIR}/linux-${PVR}-pf"
+
+PATCHES=( "${DISTDIR}/${P}.patch" )
+
+K_EXTRAEINFO="For more info on pf-sources and details on how to report problems,
+ see: ${HOMEPAGE}."
+
+pkg_setup() {
+ ewarn ""
+ ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the pf developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds. Thank you."
+ ewarn ""
+
+ kernel-2_pkg_setup
+}
+
+src_prepare() {
+ # kernel-2_src_prepare doesn't apply PATCHES().
+ default
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ elog "Optional features:"
+ optfeature "Userspace KSM helper" sys-process/uksmd
+}