summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2021-08-13 16:10:50 +0300
committerJoonas Niilola <juippis@gentoo.org>2021-08-13 16:11:15 +0300
commit8fd99508452058b1974cfca6c30f962cc34c1ea9 (patch)
treea01ae9b86915939246924ee197b5bbe551acb808 /sys-kernel/pf-sources
parentapp-misc/piper: Remove flake8 test (diff)
downloadgentoo-8fd99508452058b1974cfca6c30f962cc34c1ea9.tar.gz
gentoo-8fd99508452058b1974cfca6c30f962cc34c1ea9.tar.bz2
gentoo-8fd99508452058b1974cfca6c30f962cc34c1ea9.zip
sys-kernel/pf-sources: add 5.13-pf5
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-kernel/pf-sources')
-rw-r--r--sys-kernel/pf-sources/Manifest1
-rw-r--r--sys-kernel/pf-sources/pf-sources-5.13_p5.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/sys-kernel/pf-sources/Manifest b/sys-kernel/pf-sources/Manifest
index 533eefd151b5..0d69ceff609b 100644
--- a/sys-kernel/pf-sources/Manifest
+++ b/sys-kernel/pf-sources/Manifest
@@ -18,5 +18,6 @@ DIST pf-sources-5.12_p6.patch 5790826 BLAKE2B 286f6311197cb12613e9a082896c081071
DIST pf-sources-5.13_p2.patch 2756507 BLAKE2B 8602f98e8fc857621418513956ed9103404d4e690420f3631c9c63ce4939a4cbdd4c05ddcc0c43c9db82369337e220c9bded31055b567f138249bf3e089eea95 SHA512 2b18e4b7d408b1cdb0c857e2bab71fbc9b20cc7616608f6056940ecb1318192539abfaf1147e663b7285085fee4d7c9117fe5a33e0db7ce0ef6e76ee27757169
DIST pf-sources-5.13_p3.patch 5055786 BLAKE2B c19d0d447bdd6c8204a0c61a84592ee0d6f7fd09a4142af2f8cf9d075311dc7fbad94c78261415b6d8c0f8cc9ef408c2b8e35ee2780320b61e1050e332cdf5d2 SHA512 bff89ba11ab81b5ac3903bdbf271952a59ecf360d071a9c2c375c1eb4a4e2c478e354f7119e3ce97fd6996709d733cf305ab2ecd9eaf8655e414f0b55494da11
DIST pf-sources-5.13_p4.patch 5640578 BLAKE2B fb3cbecbe1d6498e5fc6bab28ff7b7588733d377228dbff496bb31a3efe5063cce9410cf6077a7672986d747cc05c807078718420a200416bbb6bb0f0609251f SHA512 292920775925306e37c9de2860b3dd12e992d14c70e4c0fd38bb5c35227aac168e976fe251c9c4b51c9509e2cb8737c26da3b18d4959c2888891e189248caf45
+DIST pf-sources-5.13_p5.patch 6877998 BLAKE2B 6f4cfe4c2c98d56309ce57b4cb0eaab1c59ecf6919e3c91cccd5d31421ca440d6333f7966ea53462d1a72e3769ef6ff8e5165376111b84f4484286fa46d69a6b SHA512 dd694c06721f3efffcbd1beca934bbea50012309165ce3c4f325ca5d168995409bf5f3ede670800059cc1941b216d7d50c28eb37250da4edfe6b2e17af834645
DIST prjc_v5.13-r1.patch 258898 BLAKE2B 013be3c3e9b342268359ecbcc10c7b95c7fe3741d2b9058db87da59d40aa9b34db898d31f1f1a0dab80598cab313499d8083ccea141c5200b5593c9d44647de7 SHA512 ad9276a80e28eec461a307ad44a1ed5acebf810b14ce8c9e6f1dc211be6ed7e72f535175fb65f3115fa217f8b635122c65c2c002ff00ba458c867d8bb6257f36
DIST prjc_v5.13-r2.patch 257231 BLAKE2B 943d3035035cdd1744ce0e075441224ffce04a1324dc9adfb355003b1fa6bcced1f63989845d1677ada0eac78f39b01d95d3fc7676c79b68858e8748c91b70d7 SHA512 1d9c80813e8f842b8b5da8b52e4348f329ef415b8cbef0a46f17eee64bf22fa8b1e443ae84ec9e7cf7ccff339d4b4bb2df9dfc894eea438e80f07446c82992db
diff --git a/sys-kernel/pf-sources/pf-sources-5.13_p5.ebuild b/sys-kernel/pf-sources/pf-sources-5.13_p5.ebuild
new file mode 100644
index 000000000000..be9165376fa7
--- /dev/null
+++ b/sys-kernel/pf-sources/pf-sources-5.13_p5.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# Define what default functions to run
+ETYPE="sources"
+
+# No 'experimental' USE flag provided, but we still want to use genpatches
+K_EXP_GENPATCHES_NOUSE="1"
+
+# Just get basic genpatches, -pf patch set already includes vanilla-linux updates
+K_GENPATCHES_VER="1"
+
+# -pf already sets EXTRAVERSION to kernel Makefile
+K_NOSETEXTRAVERSION="1"
+
+# Not supported by the Gentoo security team
+K_SECURITY_UNSUPPORTED="1"
+
+# We want the very basic patches from gentoo-sources, experimental patch is
+# already included in pf-sources
+K_WANT_GENPATCHES="base extras"
+
+SHPV="${PV/_p*/}"
+
+inherit kernel-2 optfeature
+detect_version
+
+DESCRIPTION="Linux kernel fork that includes the pf-kernel patchset and Gentoo's genpatches"
+HOMEPAGE="https://gitlab.com/post-factum/pf-kernel/-/wikis/README
+ https://dev.gentoo.org/~mpagano/genpatches/"
+SRC_URI="${KERNEL_URI}
+ https://github.com/pfactum/pf-kernel/compare/v${SHPV}...v${SHPV}-pf${PV/*_p/}.diff -> ${P}.patch
+ https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${SHPV}-${K_GENPATCHES_VER}.base.tar.xz
+ https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${SHPV}-${K_GENPATCHES_VER}.extras.tar.xz
+ https://gitlab.com/alfredchen/projectc/-/raw/master/${SHPV}/prjc_v${SHPV}-r2.patch
+ https://raw.githubusercontent.com/GKernelCI/linux-patches/5.12/5021_BMQ-and-PDS-gentoo-defaults-v5.12-r0.patch"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+S="${WORKDIR}/linux-${PVR}-pf"
+
+PATCHES=( "${DISTDIR}/${P}.patch"
+ "${DISTDIR}/prjc_v${SHPV}-r2.patch"
+ "${DISTDIR}/5021_BMQ-and-PDS-gentoo-defaults-v5.12-r0.patch" )
+
+K_EXTRAEINFO="For more info on pf-sources and details on how to report problems,
+ see: ${HOMEPAGE}."
+
+pkg_setup() {
+ ewarn ""
+ ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the pf developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds. Thank you."
+ ewarn ""
+
+ kernel-2_pkg_setup
+}
+
+src_prepare() {
+ # kernel-2_src_prepare doesn't apply PATCHES().
+ default
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ optfeature "userspace KSM helper" sys-process/uksmd
+}