summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2019-01-11 00:27:53 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2019-01-11 00:27:53 -0800
commitc26c3cc4ff94638d19a5dbcac14ec6d1ea05da68 (patch)
treee423bc8aba964c85931dc46a9aa1cd4e5a1eda21 /sys-kernel/raspberrypi-sources/raspberrypi-sources-4.19.9999.ebuild
parentsys-apps/timer_entropyd: take over, add ~arm (diff)
downloadgentoo-c26c3cc4ff94638d19a5dbcac14ec6d1ea05da68.tar.gz
gentoo-c26c3cc4ff94638d19a5dbcac14ec6d1ea05da68.tar.bz2
gentoo-c26c3cc4ff94638d19a5dbcac14ec6d1ea05da68.zip
sys-kernel/raspberrypi-sources: add 4.19 LTS branch
Package-Manager: Portage-2.3.54, Repoman-2.3.12 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'sys-kernel/raspberrypi-sources/raspberrypi-sources-4.19.9999.ebuild')
-rw-r--r--sys-kernel/raspberrypi-sources/raspberrypi-sources-4.19.9999.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.19.9999.ebuild b/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.19.9999.ebuild
new file mode 100644
index 000000000000..76139074cd9f
--- /dev/null
+++ b/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.19.9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ETYPE=sources
+K_DEFCONFIG="bcmrpi_defconfig"
+K_SECURITY_UNSUPPORTED=1
+EXTRAVERSION="-${PN}/-*"
+inherit kernel-2
+detect_version
+detect_arch
+
+inherit git-r3 versionator
+EGIT_REPO_URI="https://github.com/raspberrypi/linux.git -> raspberrypi-linux.git"
+EGIT_BRANCH="rpi-$(get_version_component_range 1-2).y"
+EGIT_CHECKOUT_DIR="${WORKDIR}/linux-${PV}-raspberrypi"
+
+DESCRIPTION="Raspberry PI kernel sources"
+HOMEPAGE="https://github.com/raspberrypi/linux"
+
+KEYWORDS=""
+
+src_unpack() {
+ git-r3_src_unpack
+ unpack_set_extraversion
+}