summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Lamm <expeditioneer@gentoo.org>2022-12-22 12:39:42 +0100
committerDennis Lamm <expeditioneer@gentoo.org>2023-01-05 06:50:55 +0100
commit2c209c49619916945a58260832d389149394991f (patch)
tree175586c882ef01d0ed7764d7582685e6b52a6af0 /sys-kernel/raspberrypi-sources
parentapp-containers/docker: drop 20.10.17 (diff)
downloadgentoo-2c209c49619916945a58260832d389149394991f.tar.gz
gentoo-2c209c49619916945a58260832d389149394991f.tar.bz2
gentoo-2c209c49619916945a58260832d389149394991f.zip
sys-kernel/raspberrypi-sources: add 5.15.76_p20221104
Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org>
Diffstat (limited to 'sys-kernel/raspberrypi-sources')
-rw-r--r--sys-kernel/raspberrypi-sources/Manifest1
-rw-r--r--sys-kernel/raspberrypi-sources/raspberrypi-sources-5.15.76_p20221104.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/sys-kernel/raspberrypi-sources/Manifest b/sys-kernel/raspberrypi-sources/Manifest
index 03f4bcb59fcd..fc1ca89a8641 100644
--- a/sys-kernel/raspberrypi-sources/Manifest
+++ b/sys-kernel/raspberrypi-sources/Manifest
@@ -5,3 +5,4 @@ DIST genpatches-5.15-22.extras.tar.xz 3876 BLAKE2B 95daac6c95b82d628c0551b4e18e7
DIST linux-5.10.63_p20211029-raspberrypi.tar.gz 186550447 BLAKE2B 44e04467a63c5761c252280c5fbff48c3fa058891ff03623ed7fb872f0a22883ed2e3b8703847e30c1a6f5cf523db1248f027c89ce1558280f1012fa300308a7 SHA512 b050f74b5a62d355cd630d41f2f63df285662347048ed97db1bac2a74f1cefeddb31b7b352aa509e90d7f03832ad2ca8e1e476d8eac62b334132a3ab308559fc
DIST linux-5.15.32_p20220331-raspberrypi.tar.gz 199328000 BLAKE2B 06bfd61bfa94666101e0092246bfc3449ad6278f2a85104511320b27c76e5677011c7ee723f4af7f445d21dccd02ff40e73d7bfcf2fdd2f287465e2f0ff586f5 SHA512 bf20a5ea32975de8b88842f639f3e4bd2e92c51846fc00ddfca9cc4040590983d9820cfa19836bf54061780f9e8c0a1293e8aa74a7da20e2e7edd84b3932f8d7
DIST linux-5.15.61_p20220830-raspberrypi.tar.gz 199608883 BLAKE2B 53754553129f866ab27eb3e4f2d8720bddfba3a642fe505b9d5a0c819fdb8c714082de9c94d833719385b956b8463dbb0a0a4c6a63cfe322539652d44df7a96b SHA512 4c6711ef4999c7e5a5df96bebdcc67b3f1fca274f0b3b3081543df11711cf000cc507044a4d86e607b7c015aafbbd3b3e92d7ee459429b7254f6222e9a6aa7e8
+DIST linux-5.15.76_p20221104-raspberrypi.tar.gz 199660690 BLAKE2B 899714102e52904b7a37d155e42e94ed4b0e6c6600ac40fbd3cf66d15f84bb6d06afa7acf5c9624f44e9888d03d101823b419547d7ad8e566b4e55aaa077f11b SHA512 648262937e0afdb331678e0b2f913ad22788f1373f9ecd0d495e748a78399d6a69e93024268e1c0567acb4b1c9242b3ca6bd060e73b91a77529a93e4e29181c6
diff --git a/sys-kernel/raspberrypi-sources/raspberrypi-sources-5.15.76_p20221104.ebuild b/sys-kernel/raspberrypi-sources/raspberrypi-sources-5.15.76_p20221104.ebuild
new file mode 100644
index 000000000000..d77c92e734f6
--- /dev/null
+++ b/sys-kernel/raspberrypi-sources/raspberrypi-sources-5.15.76_p20221104.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ETYPE=sources
+K_DEFCONFIG="bcmrpi_defconfig"
+K_SECURITY_UNSUPPORTED=1
+EXTRAVERSION="-${PN}/-*"
+
+K_EXP_GENPATCHES_NOUSE=1
+K_GENPATCHES_VER=22
+K_DEBLOB_AVAILABLE=0
+K_WANT_GENPATCHES="base extras"
+
+inherit kernel-2 linux-info
+detect_version
+detect_arch
+
+MY_P=$(ver_cut 4-)
+MY_P="1.${MY_P/p/}"
+
+DESCRIPTION="Raspberry Pi kernel sources"
+HOMEPAGE="https://github.com/raspberrypi/linux"
+SRC_URI="
+ https://github.com/raspberrypi/linux/archive/${MY_P}.tar.gz -> linux-${KV_FULL}.tar.gz
+ ${GENPATCHES_URI}
+"
+
+KEYWORDS="~arm ~arm64"
+
+PATCHES=("${FILESDIR}"/${PN}-5.15.32-gentoo-kconfig.patch)
+
+UNIPATCH_EXCLUDE="
+ 10*
+ 15*
+ 2000
+ 29*
+ 3000
+ 4567"
+
+pkg_setup() {
+ ewarn ""
+ ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the raspberrypi developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds. Thank you."
+ ewarn ""
+
+ kernel-2_pkg_setup
+}
+
+universal_unpack() {
+ unpack linux-${KV_FULL}.tar.gz
+
+ # We want to rename the unpacked directory to a nice normalised string
+ # bug #762766
+ mv "${WORKDIR}"/linux-${MY_P} "${WORKDIR}"/linux-${KV_FULL} || die
+
+ # remove all backup files
+ find . -iname "*~" -exec rm {} \; 2>/dev/null
+}
+
+src_prepare() {
+ default
+ kernel-2_src_prepare
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}