summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2017-07-13 01:35:54 +0300
committerAlexey Shvetsov <alexxy@gentoo.org>2017-07-13 01:35:54 +0300
commitfba2502eca9ec70c0640d09535f66107c9ef0d6e (patch)
tree8429f31df4856c41dc418a99c8f03235b7827358 /sys-kernel/raspberrypi-sources
parentwww-apps/chromedriver-bin: remove ~x86, not supported by www-client/google-ch... (diff)
downloadgentoo-fba2502eca9ec70c0640d09535f66107c9ef0d6e.tar.gz
gentoo-fba2502eca9ec70c0640d09535f66107c9ef0d6e.tar.bz2
gentoo-fba2502eca9ec70c0640d09535f66107c9ef0d6e.zip
sys-kernel/raspberrypi-sources: Version bump
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'sys-kernel/raspberrypi-sources')
-rw-r--r--sys-kernel/raspberrypi-sources/raspberrypi-sources-4.11.9999.ebuild27
-rw-r--r--sys-kernel/raspberrypi-sources/raspberrypi-sources-4.12.9999.ebuild27
2 files changed, 54 insertions, 0 deletions
diff --git a/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.11.9999.ebuild b/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.11.9999.ebuild
new file mode 100644
index 000000000000..1e0ef374a717
--- /dev/null
+++ b/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.11.9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ETYPE=sources
+K_DEFCONFIG="bcmrpi_defconfig"
+K_SECURITY_UNSUPPORTED=1
+EXTRAVERSION="-${PN}/-*"
+inherit kernel-2
+detect_version
+detect_arch
+
+inherit git-2 versionator
+EGIT_REPO_URI=https://github.com/raspberrypi/linux.git
+EGIT_PROJECT="raspberrypi-linux.git"
+EGIT_BRANCH="rpi-$(get_version_component_range 1-2).y"
+
+DESCRIPTION="Raspberry PI kernel sources"
+HOMEPAGE="https://github.com/raspberrypi/linux"
+
+KEYWORDS=""
+
+src_unpack() {
+ git-2_src_unpack
+ unpack_set_extraversion
+}
diff --git a/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.12.9999.ebuild b/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.12.9999.ebuild
new file mode 100644
index 000000000000..1e0ef374a717
--- /dev/null
+++ b/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.12.9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ETYPE=sources
+K_DEFCONFIG="bcmrpi_defconfig"
+K_SECURITY_UNSUPPORTED=1
+EXTRAVERSION="-${PN}/-*"
+inherit kernel-2
+detect_version
+detect_arch
+
+inherit git-2 versionator
+EGIT_REPO_URI=https://github.com/raspberrypi/linux.git
+EGIT_PROJECT="raspberrypi-linux.git"
+EGIT_BRANCH="rpi-$(get_version_component_range 1-2).y"
+
+DESCRIPTION="Raspberry PI kernel sources"
+HOMEPAGE="https://github.com/raspberrypi/linux"
+
+KEYWORDS=""
+
+src_unpack() {
+ git-2_src_unpack
+ unpack_set_extraversion
+}