summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Linden <karl.j.linden@gmail.com>2018-09-22 16:39:58 +0200
committerAlice Ferrazzi <alicef@gentoo.org>2018-09-28 06:39:27 +0000
commit0b3daacb78bea683c9162347a4bbc0470a1ecb43 (patch)
treeff8a94e4a04a62cf419350b6d7bc3c54aa495080 /sys-kernel/rt-sources/rt-sources-4.14.71_p44.ebuild
parentsys-kernel/rt-sources: version bump to 4.4.157_p174 (diff)
downloadgentoo-0b3daacb78bea683c9162347a4bbc0470a1ecb43.tar.gz
gentoo-0b3daacb78bea683c9162347a4bbc0470a1ecb43.tar.bz2
gentoo-0b3daacb78bea683c9162347a4bbc0470a1ecb43.zip
sys-kernel/rt-sources: version bump to 4.14.71_p44
Package-Manager: Portage-2.3.49, Repoman-2.3.11 Signed-off-by: Karl Linden <karl.j.linden@gmail.com> Signed-off-by: Alice Ferrazzi <alicef@gentoo.org>
Diffstat (limited to 'sys-kernel/rt-sources/rt-sources-4.14.71_p44.ebuild')
-rw-r--r--sys-kernel/rt-sources/rt-sources-4.14.71_p44.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/sys-kernel/rt-sources/rt-sources-4.14.71_p44.ebuild b/sys-kernel/rt-sources/rt-sources-4.14.71_p44.ebuild
new file mode 100644
index 000000000000..489dbd6243b5
--- /dev/null
+++ b/sys-kernel/rt-sources/rt-sources-4.14.71_p44.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+ETYPE="sources"
+KEYWORDS="~amd64"
+
+HOMEPAGE="https://www.kernel.org/pub/linux/kernel/projects/rt/"
+
+inherit eapi7-ver
+
+CKV="$(ver_cut 1-3)"
+K_SECURITY_UNSUPPORTED="1"
+K_DEBLOB_AVAILABLE="1"
+RT_PATCHSET="${PV/*_p}"
+
+inherit kernel-2
+detect_version
+
+K_BRANCH_ID="${KV_MAJOR}.${KV_MINOR}"
+RT_FILE="patch-${K_BRANCH_ID}.${KV_PATCH}-rt${RT_PATCHSET}.patch.xz"
+RT_URI="mirror://kernel/linux/kernel/projects/rt/${K_BRANCH_ID}/${RT_FILE} \
+ mirror://kernel/linux/kernel/projects/rt/${K_BRANCH_ID}/older/${RT_FILE}"
+
+DESCRIPTION="Full Linux ${K_BRANCH_ID} kernel sources with the CONFIG_PREEMPT_RT patch"
+SRC_URI="${KERNEL_URI} ${RT_URI}"
+
+KV_FULL="${PVR/_p/-rt}"
+S="${WORKDIR}/linux-${KV_FULL}"
+
+UNIPATCH_LIST="${DISTDIR}/${RT_FILE}"
+UNIPATCH_STRICTORDER="yes"
+
+src_prepare() {
+ default
+
+ # 627796
+ sed \
+ "s/default PREEMPT_NONE/default PREEMPT_RT_FULL/g" \
+ -i "${S}/kernel/Kconfig.preempt"
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ ewarn
+ ewarn "${PN} are *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the RT project developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds."
+ ewarn
+}
+
+K_EXTRAEINFO="For more info on rt-sources and details on how to report problems, see: \
+${HOMEPAGE}."