summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlice Ferrazzi <alicef@gentoo.org>2021-08-23 23:24:19 +0900
committerAlice Ferrazzi <alicef@gentoo.org>2021-08-23 23:25:34 +0900
commita60220d85f87e1fe4b0b143e65dcbef807ae82bf (patch)
tree3d2c42a19566ddaa8e3881b42f6cd51abe016831 /sys-kernel/rt-sources/rt-sources-5.4.138_p62.ebuild
parentdev-util/nvidia-cuda-toolkit: support GCC 11, take #2 (diff)
downloadgentoo-a60220d85f87e1fe4b0b143e65dcbef807ae82bf.tar.gz
gentoo-a60220d85f87e1fe4b0b143e65dcbef807ae82bf.tar.bz2
gentoo-a60220d85f87e1fe4b0b143e65dcbef807ae82bf.zip
sys-kernel/rt-sources: rt-sources 5.4.138_p62
Move to EAPI8 Remove deblob as incompatibility with python2 Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Alice Ferrazzi <alicef@gentoo.org>
Diffstat (limited to 'sys-kernel/rt-sources/rt-sources-5.4.138_p62.ebuild')
-rw-r--r--sys-kernel/rt-sources/rt-sources-5.4.138_p62.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/sys-kernel/rt-sources/rt-sources-5.4.138_p62.ebuild b/sys-kernel/rt-sources/rt-sources-5.4.138_p62.ebuild
new file mode 100644
index 000000000000..337b873dda4d
--- /dev/null
+++ b/sys-kernel/rt-sources/rt-sources-5.4.138_p62.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+ETYPE="sources"
+KEYWORDS="~amd64 ~arm64"
+
+HOMEPAGE="https://wiki.linuxfoundation.org/realtime/start"
+
+CKV="$(ver_cut 1-3)"
+K_SECURITY_UNSUPPORTED="1"
+RT_PATCHSET="${PV/*_p}"
+
+inherit kernel-2
+detect_version
+
+K_BRANCH_ID="${KV_MAJOR}.${KV_MINOR}"
+RT_FILE="patch-${K_BRANCH_ID}.${KV_PATCH}-rt${RT_PATCHSET}.patch.xz"
+RT_URI="https://www.kernel.org/pub/linux/kernel/projects/rt/${K_BRANCH_ID}/${RT_FILE} \
+ https://www.kernel.org/pub/linux/kernel/projects/rt/${K_BRANCH_ID}/older/${RT_FILE}"
+
+DESCRIPTION="Full Linux ${K_BRANCH_ID} kernel sources with the CONFIG_PREEMPT_RT patch"
+SRC_URI="${KERNEL_URI} ${RT_URI}"
+
+KV_FULL="${PVR/_p/-rt}"
+S="${WORKDIR}/linux-${KV_FULL}"
+
+UNIPATCH_LIST="${DISTDIR}/${RT_FILE}"
+UNIPATCH_STRICTORDER="yes"
+
+src_prepare() {
+ default
+
+ # 627796
+ sed \
+ "s/default PREEMPT_NONE/default PREEMPT_RT/g" \
+ -i "${S}/kernel/Kconfig.preempt" || die "sed failed"
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ ewarn
+ ewarn "${PN} are *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the RT project developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds."
+ ewarn
+}
+
+K_EXTRAEINFO="For more info on rt-sources and details on how to report problems, see: \
+${HOMEPAGE}."