summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlice Ferrazzi <alicef@gentoo.org>2022-01-06 21:58:45 +0900
committerAlice Ferrazzi <alicef@gentoo.org>2022-01-06 23:06:36 +0900
commit95b2f29f87484213cd01641152b4c5aa1b76fa4f (patch)
tree99c4a10c6e8440f80c50d14dfba73f67e76a5c27 /sys-kernel/rt-sources
parentsys-kernel/rt-sources: Add rt sources 5.10.90-rt60 (diff)
downloadgentoo-95b2f29f87484213cd01641152b4c5aa1b76fa4f.tar.gz
gentoo-95b2f29f87484213cd01641152b4c5aa1b76fa4f.tar.bz2
gentoo-95b2f29f87484213cd01641152b4c5aa1b76fa4f.zip
sys-kernel/rt-sources: Add rt sources 5.4.161-rt67
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Alice Ferrazzi <alicef@gentoo.org>
Diffstat (limited to 'sys-kernel/rt-sources')
-rw-r--r--sys-kernel/rt-sources/Manifest2
-rw-r--r--sys-kernel/rt-sources/rt-sources-5.4.161_p67.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/sys-kernel/rt-sources/Manifest b/sys-kernel/rt-sources/Manifest
index 6f4c1dcef058..1533c05a2f96 100644
--- a/sys-kernel/rt-sources/Manifest
+++ b/sys-kernel/rt-sources/Manifest
@@ -31,3 +31,5 @@ DIST patch-5.15.3-rt21.patch.xz 81128 BLAKE2B 685ef5d14e7784ec34d01dec71ae7e8b5b
DIST patch-5.15.3.xz 290732 BLAKE2B 62544d1c3187321db6b2dfc7f1d910ddbcfc2b9d2977087d0e1fba12dde33df2d74ea62ced1646243db68a8d386b22bc5c80a955c1e65e77084b06e224586d93 SHA512 cf8b69a3aa725e0ebbe767ac28b7b99de53ee2436a6883e54ee330d17bbdb4d88c147ef1082c3c02a20649ecdc1e363961d9b210e56018c92daff7b889ff2db5
DIST patch-5.4.154-rt65.patch.xz 182592 BLAKE2B fb2e5ac1b8d9b5fe1852deeca9b07513c544b1a576c3012eb93a9e131c1bd53c26a3a6a40ace93019b0a1a5ec66e57b9d3058e391314d9a9b6b3963154d814fa SHA512 74c092fc13918e5e424a838c45031b756e20d794baaffabfed551f222cd32198a16ddff7eadda4a3d682b13e31d8ea92b1cc66cd8f27a9f05db786671a29d796
DIST patch-5.4.154.xz 3419760 BLAKE2B d67193634055eba94444c384c624f70189c7dcfce7024f54312be3239f0215c2687e04568359d391700e8b7892a41f56c9005b42ce9e384996c85f976164c32d SHA512 c6b906a73db666255c0cefec4ed5651ee5f7383d9c5b8696d73f2702a3cb43a5373b7b8022b13cd4d86fb48b3dfc57a25f370916b6b6aaa003c7429602894eb5
+DIST patch-5.4.161-rt67.patch.xz 183380 BLAKE2B 858077423d1b580de96397be489fceed1f8586f71ca471433680749e7f71f47bf5964af8f3771b1d8dbebb10430c2ab752a844c69baf15c88437c2298eb5b620 SHA512 5137433e37de382e6e65880279f841a30d41842c23cb2772008770dcfefc916fe0301f7e107a5c882f6980c67fbd66c8ef052726b81c8bce03a3269bc33df826
+DIST patch-5.4.161.xz 3511784 BLAKE2B 962acb4e8c823a3e245d0a7f07f9104b5e0efc50243d24cfb98f180c9e5d276694735c899694f36917362d1a0f376dc6d7fdfc9cfff94b935aa840178c6c16ac SHA512 3d6e79bc0a6217ae14ef7aae18fc595c8138e95d0e0e0857695cb147e2a17f70dc27cb302ba3890e52a2553ec2f95063704b50c1191369ec92a24a4c90eee807
diff --git a/sys-kernel/rt-sources/rt-sources-5.4.161_p67.ebuild b/sys-kernel/rt-sources/rt-sources-5.4.161_p67.ebuild
new file mode 100644
index 000000000000..50276aa2db47
--- /dev/null
+++ b/sys-kernel/rt-sources/rt-sources-5.4.161_p67.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+ETYPE="sources"
+KEYWORDS="~amd64 ~arm64"
+
+HOMEPAGE="https://wiki.linuxfoundation.org/realtime/start"
+
+CKV="$(ver_cut 1-3)"
+K_SECURITY_UNSUPPORTED="1"
+RT_PATCHSET="${PV/*_p}"
+
+inherit kernel-2
+detect_version
+
+K_BRANCH_ID="${KV_MAJOR}.${KV_MINOR}"
+RT_FILE="patch-${K_BRANCH_ID}.${KV_PATCH}-rt${RT_PATCHSET}.patch.xz"
+RT_URI="https://www.kernel.org/pub/linux/kernel/projects/rt/${K_BRANCH_ID}/${RT_FILE} \
+ https://www.kernel.org/pub/linux/kernel/projects/rt/${K_BRANCH_ID}/older/${RT_FILE}"
+
+DESCRIPTION="Full Linux ${K_BRANCH_ID} kernel sources with the CONFIG_PREEMPT_RT patch"
+SRC_URI="${KERNEL_URI} ${RT_URI}"
+
+KV_FULL="${PVR/_p/-rt}"
+S="${WORKDIR}/linux-${KV_FULL}"
+
+UNIPATCH_LIST="${DISTDIR}/${RT_FILE}"
+UNIPATCH_STRICTORDER="yes"
+
+src_prepare() {
+ default
+
+ # 627796
+ sed \
+ "s/default PREEMPT_NONE/default PREEMPT_RT/g" \
+ -i "${S}/kernel/Kconfig.preempt" || die "sed failed"
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ ewarn
+ ewarn "${PN} are *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the RT project developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds."
+ ewarn
+}
+
+K_EXTRAEINFO="For more info on rt-sources and details on how to report problems, see: \
+${HOMEPAGE}."