summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-01-30 08:20:54 +0100
committerMichał Górny <mgorny@gentoo.org>2020-01-30 18:26:02 +0100
commitf18599d035cfcef7e4ff033c57922bfb1367601c (patch)
tree3f343e37690a10bbdc6b5e9f94a6ebfce83d3ae5 /sys-kernel/vanilla-kernel
parentapp-text/coolreader: bump to 3.2.39 (diff)
downloadgentoo-f18599d035cfcef7e4ff033c57922bfb1367601c.tar.gz
gentoo-f18599d035cfcef7e4ff033c57922bfb1367601c.tar.bz2
gentoo-f18599d035cfcef7e4ff033c57922bfb1367601c.zip
sys-kernel/vanilla-kernel: Bump to 5.4.16
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-kernel/vanilla-kernel')
-rw-r--r--sys-kernel/vanilla-kernel/Manifest1
-rw-r--r--sys-kernel/vanilla-kernel/vanilla-kernel-5.4.16.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/sys-kernel/vanilla-kernel/Manifest b/sys-kernel/vanilla-kernel/Manifest
index 3227c7594a23..21fc586dd3e6 100644
--- a/sys-kernel/vanilla-kernel/Manifest
+++ b/sys-kernel/vanilla-kernel/Manifest
@@ -10,6 +10,7 @@ DIST linux-5.4.13.arch1.amd64.config 241498 BLAKE2B 3c6d13d84ea75247fae4f4474648
DIST linux-5.4.13.tar.xz 109463864 BLAKE2B d610a2bf375c9147b26d6e314c1e86b9f32453572c1e8a859be3ac5fa42d7ba647334ef76a92a7e1e61f78fa256692bec3d62003589017840a37947d9d5b1de0 SHA512 e7aaa541ccf66ca8373fe53794786c8b819da824b17acc497d5080f4fff5bef90bab1da531fa8f62a013f40472f5c1dfafb4bd4f42ecc1bf851042d22e72c4a7
DIST linux-5.4.14.tar.xz 109457772 BLAKE2B eb0286a193b29754562771905db13e6d2140dc577d88be8e8f91f0ab77b9adbe915bb74e89e10e5dce3763f3efce6204c973f5d3341dba9e11ecb544500be5a3 SHA512 8bf032249dd98ee557cccc3f75ea451386c3cb0a2a0f17344672856220ff98ec86f6f745d15fc09a8c5fae6ceecaaa76fd2067963eae0e942c98d56141b4e537
DIST linux-5.4.15.tar.xz 109461584 BLAKE2B 0384ac416aaca05ac73e77fae2cf85b2d773f343aa9a95191818a237354904b2c36404cbe08e373be832fa9f17c7961362dfe3be50f8cfe040c2eaddbab37da1 SHA512 be890d2f893e4470bf51ea84e60088e33420083ffd39e50d204a063e8405176035f2364333657ebabdd68bd4635ae3ea535d0c939de6c88e3e118c3619be1866
+DIST linux-5.4.16.tar.xz 109474712 BLAKE2B cf99bbd992d8e90c4255c0ce81fd27793663fb2b300ea1bf686ca21933e6ec6cd2ce7a2bea7b59e235ad70bc05519fd06e033baa0d6e881df732d3a85bc6a17c SHA512 994d0884230c258c97af8c9b1857241d34c780bc61271102707e7bd861270306b1f4c51a00d48826786d1544e8647de8c1e72fa74bf3e9a498a32b7db428337d
DIST linux-5.4.7-arch1.i686.config 241295 BLAKE2B da45f2de600fafdb48e9bb37e6f7a8ea57ed31dc6fb47062bcee694db0b824844c0556ad6a88afa33bf3a365f50c9ac6326389cfa87d0e47a012252fa1444536 SHA512 dcfd9c03cbafeeb942fd37c1f18432aeeacaff438cb88528e17aa8c28bae20090695a2acad08a707e66ecaa5851aa47b012baa6d9274c617fa8c71cde641e8ec
DIST linux-5.4.7.arch1-1.amd64.config 241598 BLAKE2B 536cce5cc23cf20e71cba7468a125557f85d8ffc3cb194dced79bd489d39f2e4ed3960816d15d1491007d11b3af466e0a74267f983dfcc5f511f9f566f7e9821 SHA512 8658db603e180c75caf76972d85ecf8a4e9c9cf6e047b4f9fc7cba0fa426f434361528c1c29b5580f116cdd23091bf9afb6635d751f3b90c4e968d16db90eac1
DIST tinycorelinux-10.1-amd64.qcow2 16842752 BLAKE2B e013e76503c335739a9623c0901ca791937a0e6b177854535cadec1e2c2cd2df588283ed3128cf652595f32264fbfe5b3bd3a8c97665fd4da344e308535be366 SHA512 c3aeb20ff8769da9211694b7f701907cc7ae7582cdfad2c2fdc008d97ebcbd9dc08245b4e8f8450e1cb304bd705345a11fe79f901a47979fee91443841d55641
diff --git a/sys-kernel/vanilla-kernel/vanilla-kernel-5.4.16.ebuild b/sys-kernel/vanilla-kernel/vanilla-kernel-5.4.16.ebuild
new file mode 100644
index 000000000000..92992f98790f
--- /dev/null
+++ b/sys-kernel/vanilla-kernel/vanilla-kernel-5.4.16.ebuild
@@ -0,0 +1,65 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kernel-build
+
+MY_P=linux-${PV}
+# https://git.archlinux.org/svntogit/packages.git/log/trunk/config?h=packages/linux
+AMD64_CONFIG_VER=5.4.13.arch1
+AMD64_CONFIG_HASH=9eed969590614a38d370a9fe04a4f5d38ba5e06e
+# https://git.archlinux32.org/packages/log/core/linux/config.i686
+I686_CONFIG_VER=5.4.13-arch1
+I686_CONFIG_HASH=95f890a9f9131e7a0e01a4f3e9c5ee423756a233
+
+DESCRIPTION="Linux kernel built from vanilla upstream sources"
+HOMEPAGE="https://www.kernel.org/"
+SRC_URI+=" https://cdn.kernel.org/pub/linux/kernel/v$(ver_cut 1).x/${MY_P}.tar.xz
+ amd64? (
+ https://git.archlinux.org/svntogit/packages.git/plain/trunk/config?h=packages/linux&id=${AMD64_CONFIG_HASH}
+ -> linux-${AMD64_CONFIG_VER}.amd64.config
+ )
+ x86? (
+ https://git.archlinux32.org/packages/plain/core/linux/config.i686?id=${I686_CONFIG_HASH}
+ -> linux-${I686_CONFIG_VER}.i686.config
+ )"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ !sys-kernel/vanilla-kernel-bin:${SLOT}"
+
+src_prepare() {
+ default
+
+ # prepare the default config
+ case ${ARCH} in
+ amd64)
+ cp "${DISTDIR}"/linux-${AMD64_CONFIG_VER}.amd64.config .config || die
+ ;;
+ x86)
+ cp "${DISTDIR}"/linux-${I686_CONFIG_VER}.i686.config .config || die
+ ;;
+ *)
+ die "Unsupported arch ${ARCH}"
+ ;;
+ esac
+
+ local config_tweaks=(
+ # shove arch under the carpet!
+ -e 's:^CONFIG_DEFAULT_HOSTNAME=:&"gentoo":'
+ # we do support x32
+ -e '/CONFIG_X86_X32/s:.*:CONFIG_X86_X32=y:'
+ # disable signatures
+ -e '/CONFIG_MODULE_SIG/d'
+ -e '/CONFIG_SECURITY_LOCKDOWN/d'
+ # disable compression to allow stripping
+ -e '/CONFIG_MODULE_COMPRESS/d'
+ # disable gcc plugins to unbreak distcc
+ -e '/CONFIG_GCC_PLUGIN_STRUCTLEAK/d'
+ )
+ sed -i "${config_tweaks[@]}" .config || die
+}