summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2021-04-01 08:28:23 +0300
committerJoonas Niilola <juippis@gentoo.org>2021-04-01 08:28:23 +0300
commit27d7838c66d9e3856a71a3c5e6b613c3e3315677 (patch)
treeabff2f8b99a55a3b7b1fbea0a3c20c847d557c9e /sys-kernel
parentapp-metrics/redis_exporter: RESTRICT=test (diff)
downloadgentoo-27d7838c66d9e3856a71a3c5e6b613c3e3315677.tar.gz
gentoo-27d7838c66d9e3856a71a3c5e6b613c3e3315677.tar.bz2
gentoo-27d7838c66d9e3856a71a3c5e6b613c3e3315677.zip
sys-kernel/pf-sources: bump to 5.11-pf6
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/pf-sources/Manifest1
-rw-r--r--sys-kernel/pf-sources/pf-sources-5.11_p6.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/sys-kernel/pf-sources/Manifest b/sys-kernel/pf-sources/Manifest
index fc17c51ba624..5c4894c9b44c 100644
--- a/sys-kernel/pf-sources/Manifest
+++ b/sys-kernel/pf-sources/Manifest
@@ -15,4 +15,5 @@ DIST pf-sources-5.11_p2.patch 2720760 BLAKE2B db2ccb4449d6ed2d545c15ef82b99d581e
DIST pf-sources-5.11_p3.patch 3932843 BLAKE2B 655d68a6cced89aeab7b71cb67d0469567201766f378371e0e6c933fb4ac48317e27c5a148dc70117550c4f09c2b8d4c7690f5f0d88754d80fe8ca9ab9bc2415 SHA512 3b1444baa42a737166c1ce7b40d616123b2df197f9f6fc3041fded977f760627603656fbb6f41c12ad008ec724d96ae81664bbaedda4f3759aec50cb5820776b
DIST pf-sources-5.11_p4.patch 4443076 BLAKE2B 294d1eb3ec09de6c5d6011913a8d831185a424a85e3bc6d245bd3ef4fe6b50d8e2b64decf398c153435de0b24c2417a7076ae854424201ce61cfdbbdedf4565f SHA512 3a14d63039e1a3701493d17b164364ef3c9167333e16aa8202b2967eebfaab3bd0c233b1e09af44a190a86a1b5599ee339f9ae06298c77404e7f99c6f9f14df7
DIST pf-sources-5.11_p5.patch 4598966 BLAKE2B 8dc474e83816d698bceeba123ceef1c6d33eba551ff85cdc121d51eb2cfc4b81fd1b7fcb63a5254560b978368ec1b24bd9c49cef38432ba3ef956399f4d4e7f2 SHA512 296dda2e6fa1fdc8706ba1547122982e261f0bde82b80c423a2bd5f7b63d98113a75912fd64c630add18eb00f9d77dd1ebf3a0ebd33db985b30484b058d50547
+DIST pf-sources-5.11_p6.patch 5055069 BLAKE2B 75ea4ce13e12762c282c51f07a4bf4553dccd864a004b6af3b2e4531795e0d05d510ca22f890344d692a63f177888a094e265282527ebfb6ef1ce3f11f192205 SHA512 68454152046bde1f412d2c2da8c30d9e57d856f28b2efc88b0038235fac04ddb32e009d2ea4bd75364fa6d17336ea445bf0fa5487846ec81f790add33544d214
DIST pf-sources-5.9_p7.patch 3027972 BLAKE2B 9247ea63b30f9d42d79303b73a900d468a71e703333932f7f15ae697cdba52c46358297023e037226c219fad5df912fb5d21e6f4b7190556ca799fa84924480e SHA512 c69e14f59bf98944b3329c65b7e2c271d74a756bc8c890130bf3cc68b4b96d31f1c33c4edb128580fcaefeb6e42dd04b1eb3d7f071b2d58bc764d26322bda8cd
diff --git a/sys-kernel/pf-sources/pf-sources-5.11_p6.ebuild b/sys-kernel/pf-sources/pf-sources-5.11_p6.ebuild
new file mode 100644
index 000000000000..0c2ef327c94c
--- /dev/null
+++ b/sys-kernel/pf-sources/pf-sources-5.11_p6.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# Define what default functions to run
+ETYPE="sources"
+
+# No 'experimental' USE flag provided, but we still want to use genpatches
+K_EXP_GENPATCHES_NOUSE="1"
+
+# Just get basic genpatches, -pf patch set already includes vanilla-linux updates
+K_GENPATCHES_VER="1"
+
+# -pf already sets EXTRAVERSION to kernel Makefile
+K_NOSETEXTRAVERSION="1"
+
+# Not supported by the Gentoo security team
+K_SECURITY_UNSUPPORTED="1"
+
+# We want the very basic patches from gentoo-sources, experimental patch is
+# already included in pf-sources
+K_WANT_GENPATCHES="base extras"
+
+SHPV="${PV/_p*/}"
+
+inherit kernel-2 optfeature
+detect_version
+
+DESCRIPTION="Linux kernel fork that includes the pf-kernel patchset and Gentoo's genpatches"
+HOMEPAGE="https://gitlab.com/post-factum/pf-kernel/-/wikis/README
+ https://dev.gentoo.org/~mpagano/genpatches/"
+SRC_URI="${KERNEL_URI}
+ https://github.com/pfactum/pf-kernel/compare/v${SHPV}...v${SHPV}-pf${PV/*_p/}.diff -> ${P}.patch
+ https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${SHPV}-${K_GENPATCHES_VER}.base.tar.xz
+ https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${SHPV}-${K_GENPATCHES_VER}.extras.tar.xz
+ https://dev.gentoo.org/~mpagano/genpatches/trunk/${SHPV}/5020_BMQ-and-PDS-io-scheduler-v${SHPV}-r2.patch
+ https://dev.gentoo.org/~mpagano/genpatches/trunk/${SHPV}/5021_BMQ-and-PDS-gentoo-defaults-v${SHPV}-r2.patch"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+S="${WORKDIR}/linux-${PVR}-pf"
+
+PATCHES=( "${DISTDIR}/${P}.patch"
+ "${DISTDIR}/5020_BMQ-and-PDS-io-scheduler-v${SHPV}-r2.patch"
+ "${DISTDIR}/5021_BMQ-and-PDS-gentoo-defaults-v${SHPV}-r2.patch"
+)
+
+K_EXTRAEINFO="For more info on pf-sources and details on how to report problems,
+ see: ${HOMEPAGE}."
+
+pkg_setup() {
+ ewarn ""
+ ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the pf developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds. Thank you."
+ ewarn ""
+
+ kernel-2_pkg_setup
+}
+
+src_prepare() {
+ # kernel-2_src_prepare doesn't apply PATCHES().
+ default
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ elog "Optional features:"
+ optfeature "Userspace KSM helper" sys-process/uksmd
+}