summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-01-02 14:15:04 +0100
committerMichał Górny <mgorny@gentoo.org>2020-01-02 14:19:43 +0100
commit2fa473a4300a20c9ca881eac6cfec9828d823e9c (patch)
tree3995d04d42594ce3d897b19c1bf7a5eea60ce5d0 /sys-kernel
parentsys-kernel/vanilla-kernel-bin: Create linux symlink when none (diff)
downloadgentoo-2fa473a4300a20c9ca881eac6cfec9828d823e9c.tar.gz
gentoo-2fa473a4300a20c9ca881eac6cfec9828d823e9c.tar.bz2
gentoo-2fa473a4300a20c9ca881eac6cfec9828d823e9c.zip
sys-kernel/vanilla-kernel: Create linux symlink when none exists
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/vanilla-kernel/vanilla-kernel-5.4.7.ebuild30
1 files changed, 18 insertions, 12 deletions
diff --git a/sys-kernel/vanilla-kernel/vanilla-kernel-5.4.7.ebuild b/sys-kernel/vanilla-kernel/vanilla-kernel-5.4.7.ebuild
index e4705ad05588..37e03a83622e 100644
--- a/sys-kernel/vanilla-kernel/vanilla-kernel-5.4.7.ebuild
+++ b/sys-kernel/vanilla-kernel/vanilla-kernel-5.4.7.ebuild
@@ -255,19 +255,25 @@ pkg_postinst() {
eend ${?} || die "Installing the kernel failed"
fi
- local symlink_target=$(readlink "${EROOT}"/usr/src/linux)
- local symlink_ver=${symlink_target#linux-}
- if [[ ${symlink_target} == linux-* && -z ${symlink_ver//[0-9.]/} ]]
- then
- local symlink_pkg=${CATEGORY}/${PN}-${symlink_ver}
- # if the current target is either being replaced, or still
- # installed (probably depclean candidate), update the symlink
- if has "${symlink_ver}" ${REPLACING_VERSIONS} ||
- has_version -r "~${symlink_pkg}"
+ if [[ ! -e ${EROOT}/usr/src/linux ]]; then
+ ebegin "Creating /usr/src/linux symlink"
+ ln -f -n -s linux-${PV} "${EROOT}"/usr/src/linux
+ eend ${?}
+ else
+ local symlink_target=$(readlink "${EROOT}"/usr/src/linux)
+ local symlink_ver=${symlink_target#linux-}
+ if [[ ${symlink_target} == linux-* && -z ${symlink_ver//[0-9.]/} ]]
then
- ebegin "Updating /usr/src/linux symlink"
- ln -f -n -s linux-${PV} "${EROOT}"/usr/src/linux
- eend ${?}
+ local symlink_pkg=${CATEGORY}/${PN}-${symlink_ver}
+ # if the current target is either being replaced, or still
+ # installed (probably depclean candidate), update the symlink
+ if has "${symlink_ver}" ${REPLACING_VERSIONS} ||
+ has_version -r "~${symlink_pkg}"
+ then
+ ebegin "Updating /usr/src/linux symlink"
+ ln -f -n -s linux-${PV} "${EROOT}"/usr/src/linux
+ eend ${?}
+ fi
fi
fi