summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2018-07-15 16:40:15 -0400
committerMike Pagano <mpagano@gentoo.org>2018-07-15 16:40:24 -0400
commit6461700cd107e3b062b2203d7363ee2a8f9e1c22 (patch)
tree406e525e79193adfee7699525041b1078bcfb4f9 /sys-kernel
parentsys-devel/dwz: version bump (bug 529570), drop old (diff)
downloadgentoo-6461700cd107e3b062b2203d7363ee2a8f9e1c22.tar.gz
gentoo-6461700cd107e3b062b2203d7363ee2a8f9e1c22.tar.bz2
gentoo-6461700cd107e3b062b2203d7363ee2a8f9e1c22.zip
sys-kernel/git-sources: Linux patch 4.18-rc5
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-4.18_rc5.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index 7bb5d54c7055..730418a85732 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -3,3 +3,4 @@ DIST patch-4.18-rc1.patch 52274025 BLAKE2B 8f3f9b01d981fbbdf4eb2b5857f8de305ccf4
DIST patch-4.18-rc2.patch 52841801 BLAKE2B b9d65a0f2afb2f75b34ca3886cb2599cf85aa60eff943d9afacb5d708b131dfdb8956b357e6e94dc5e82f21f60135d887d6a1845edac0f0b3da1b5216c5f2a16 SHA512 1fdd5360543080f53d0889ce644818672c29a27850e1cf54cddaa3d4037ff91c01ac582dbfc7bb9a7b1e265c35f1c202145c44830a03feccfd807b13654c0e66
DIST patch-4.18-rc3.patch 53031653 BLAKE2B 681fb4262705d4aaea58f43f050bbb781924c36adedbbf3c28768b1695e8bb22cf659d562dd6cd787dbe1007029646d575f10f228971d680526cc35bc1f48ce5 SHA512 ee568a9345d28a055a96a66681276ccb4240a159c57eb4d62c19ec640cf733a9be7e0b6536344be7c642cbc662ee5383399128bbc6210d627565a9f58c080a0e
DIST patch-4.18-rc4.patch 53258687 BLAKE2B 3abd80176b7de14be61a8fd6826f9eaab970c20fe1199bd64615b44dbb573e20453f6dd4c9f23e029f8b83f95356fa1936f9b9c2527e4e0c0cd9d96bfcadb723 SHA512 c57e72111add18fe27c15487fa3c54e7982511a9d1f2bd46c530396a560422ed03c5988a0b2d3cf6225eeef08637c535c6c316932d5beb214582a801f8cd0bc2
+DIST patch-4.18-rc5.patch 53496453 BLAKE2B d8211e175f4d6d0f62b3458bd19731c408999c9d00510bee99323232cc59822da9d7eddbfeaacb441066a2e8f3b543106608d67b11896952f8c87c9a6c4b1a2e SHA512 9c7dc21dad12ad7cd005ce12128d25ab36d7cb6e5dd074bcc3d26b89437ae778727e52b8535240c084512c270dc5d9a66ac87babdaa9f5f030a94c2329fc9437
diff --git a/sys-kernel/git-sources/git-sources-4.18_rc5.ebuild b/sys-kernel/git-sources/git-sources-4.18_rc5.ebuild
new file mode 100644
index 000000000000..d7f883a43cc3
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-4.18_rc5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="4.17"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.5"
+
+pkg_postinst() {
+ postinst_sources
+}