summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2020-07-20 08:04:51 +0200
committerAgostino Sarubbo <ago@gentoo.org>2020-07-20 08:04:51 +0200
commit7a4cf422271561c280ae157ad6b1aa8d6c745e86 (patch)
tree9e5aeacd56bdfe1c7c553af474b7366ee2f47b9d /sys-kernel
parentdev-lang/cxprolog: do not source Prolog files from live file system (diff)
downloadgentoo-7a4cf422271561c280ae157ad6b1aa8d6c745e86.tar.gz
gentoo-7a4cf422271561c280ae157ad6b1aa8d6c745e86.tar.bz2
gentoo-7a4cf422271561c280ae157ad6b1aa8d6c745e86.zip
sys-kernel/git-sources: Automated version bump to 5.8_rc6.
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-5.8_rc6.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index 2fbc943ae771..5489c3027001 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -4,3 +4,4 @@ DIST patch-5.8-rc2.patch 65398003 BLAKE2B 536bc4d8537587ce0324036d4649ac7c4ba2a3
DIST patch-5.8-rc3.patch 65933507 BLAKE2B a0af229faa03bcc91edd27fd09a157dda245a7e703c2c754e2917d6acbf94827db805432580760850f4b48aa3b6ae3a2431483d074eeb1a2648cb22a463f1bd5 SHA512 ddc163b322e75c40b2f4cd81e1c2e68cf1ebc9200095759948c353b75bd9dadeba4ffa704025ecbd95d8ebe9e7d2f561f2eb0f0d47dbf03d372b86bfddb31ed0
DIST patch-5.8-rc4.patch 66103533 BLAKE2B fdb7c4989bcb8d04e484c0024251678e57fb58864319f0956ecf233054ec33ec76ec5807b4bd85217e3a39bf7ced7fff94362ae6952149ac5b8a3e8460a1509c SHA512 88ef2caba06276bfd9795f2530ece2c3fed646e3d445a58fce77bc354777924c66c09098951959289228506e6aa884f8faf026d84c619caf3082702debac994f
DIST patch-5.8-rc5.patch 66428755 BLAKE2B 633a56e00102522fd7100052613fb76ddf20c416402e52fb5bf30bd6b0e9f1c99c56b94c20e1a98da51400e14e956a4b4e5f2e5acd5b095545924e77882a4a7e SHA512 041c7ea7b9093b0b93e27201016527e959d122bdeda7eed3aa8f289c72af6ea4e3aa415a2806c534a812a2bd6f1e90719a974eb1fd3693e60c0bc9c5e924e025
+DIST patch-5.8-rc6.patch 66670137 BLAKE2B af076caefbb7862fb79d7df6f72e4f06de24bea66620d8a7f2844af1f771a72352e2d30c67758ed17684734444900b88f198006523d007bc2f3b8594a91e8347 SHA512 4bae58d19119a329e2c4da99546d3a5aa8cc7a1e0be6687a3fb19b559e8bed146e5fd1b4f96abe9d1ebfc8febe9e726dbd6a92c87b9cca2bfab52aa47bfd60e1
diff --git a/sys-kernel/git-sources/git-sources-5.8_rc6.ebuild b/sys-kernel/git-sources/git-sources-5.8_rc6.ebuild
new file mode 100644
index 000000000000..9412304f02dc
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-5.8_rc6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="5.7"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.5"
+
+pkg_postinst() {
+ postinst_sources
+}