summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2017-10-01 18:33:27 -0400
committerMike Pagano <mpagano@gentoo.org>2017-10-01 18:33:40 -0400
commitb437b0f5c596867349a3c27c01b88e298baec440 (patch)
tree7cc96527ada36fd5c9babadf3fc3b55bd9efc1b7 /sys-kernel
parentdev-lisp/asdf: Installs asdf.info only when >=dev-lisp/sbcl-1.4.0 (diff)
downloadgentoo-b437b0f5c596867349a3c27c01b88e298baec440.tar.gz
gentoo-b437b0f5c596867349a3c27c01b88e298baec440.tar.bz2
gentoo-b437b0f5c596867349a3c27c01b88e298baec440.zip
sys-kernel/git-sources: Linux patch 4.14-rc3
Package-Manager: Portage-2.3.8, Repoman-2.3.1
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-4.14_rc3.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index 85cea291de62..1a21a4d107ce 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -1,3 +1,4 @@
DIST linux-4.13.tar.xz 100579888 SHA256 2db3d6066c3ad93eb25b973a3d2951e022a7e975ee2fa7cbe5bddf84d9a49a2c SHA512 a557c2f0303ae618910b7106ff63d9978afddf470f03cb72aa748213e099a0ecd5f3119aea6cbd7b61df30ca6ef3ec57044d524b7babbaabddf8b08b8bafa7d2 WHIRLPOOL d3d332e02cd3c5056c76c28cf1f81504c6f7b8f2caed7238e7dd7866747fb03154b88d8d7aec4d0eddf5760624bc7d6c5485fb52a3e32d098a2742eba96c0d05
DIST patch-4.14-rc1.patch 49971200 SHA256 bdda6ba668374a3d5790a30a5bc12c674b199be16fb37646f896827359e3b006 SHA512 6937508f1eb09d428c1e74123c94d303281f89c1bfb8884555c9d5e463b98b0fe84a7fd11f5b1e7bff3b8ed1925ed896f42d64745c71a2685599d3fd385b2efd WHIRLPOOL 18fdd10b5def278a91910e56ebd7083e5d54e972c53b78ef1ab04f24d423f96f7ad337f5ee542d30e75150897b20b2620073773f85db984b2db59cf71d350226
DIST patch-4.14-rc2.patch 50397184 SHA256 05c079b902c0b886cdb27c37d38e52f3d8ae7dd66092aedf3e1d9a385cef97dd SHA512 af089483e9351d75c65b880ec0448555b4c5887d7ceb78a574bcf539d1773cfc35a56251d41ddc7aeaf67dee4e0705db7286e2990caaa7ecc5d18cf8eb4effaa WHIRLPOOL 5a50fa248027ccca2178338779205e2f29a0187b34175bf0b40a81be37c9013ef2b3929ddfced7a74786b43614dc672c2e09d676a415ce1e1ef4d42657234c79
+DIST patch-4.14-rc3.patch 50656199 SHA256 45b73aefcf8e9e7de6282bb0107b83aec8a345d5653111e30fbd8be398906eb7 SHA512 8fd1a56254be222963e8878a5d357012b13dc280eca3c147a03aa50f28457baad7100834e074f325ee62a18648b790d92e4978ef36e8dd538306cd1a2ddc7319 WHIRLPOOL b32b0c16c20af1912e54e367cd93eec61776914228e3cde3a4b38f89122f3338251eff8f831f359f4d27c8ed25ddef130f68c03067550dcab24245d092bce95d
diff --git a/sys-kernel/git-sources/git-sources-4.14_rc3.ebuild b/sys-kernel/git-sources/git-sources-4.14_rc3.ebuild
new file mode 100644
index 000000000000..7f2595c38a35
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-4.14_rc3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="4.13"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.5"
+
+pkg_postinst() {
+ postinst_sources
+}