summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2017-06-19 12:50:08 -0400
committerMike Pagano <mpagano@gentoo.org>2017-06-19 12:50:19 -0400
commitb8855ddc2bb817ae2dbbc16a545ee04597045ce9 (patch)
treed02164df21e69f13540d116cdfbb6592ea28a20b /sys-kernel
parentdev-php/PEAR-Pager: Drop old (diff)
downloadgentoo-b8855ddc2bb817ae2dbbc16a545ee04597045ce9.tar.gz
gentoo-b8855ddc2bb817ae2dbbc16a545ee04597045ce9.tar.bz2
gentoo-b8855ddc2bb817ae2dbbc16a545ee04597045ce9.zip
sys-kernel/git-sources: Linux patch 4.12-rc6
Package-Manager: Portage-2.3.5, Repoman-2.3.1
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-4.12_rc6.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index 48c25df94fc7..be4199ec55dc 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -4,3 +4,4 @@ DIST patch-4.12-rc2.patch 89563541 SHA256 76e32580cc6fa58e016453856267d61e2b2c46
DIST patch-4.12-rc3.patch 89897831 SHA256 d7cd828bdeb0d8b2a584ae87449ab88df8f4344d04add02a4e1ada8067ddbd34 SHA512 82ada025b3b28ecd9effccc4c414c4e6f1dd24c06f4f62eced557e30ccc41c1575927129b6c7dd956ad99d8561522ed5dc3255037b6c3fcedef88b9aa11ebaa4 WHIRLPOOL a6af83a4918a60c2b0fc77617c374751a1fc5bf37d5a10abcffc07bf9686a3904d49546b28a33481c8f8aa8ab0cd9fb410f8ce709049223b39f3569f9ddec6fb
DIST patch-4.12-rc4.patch 90081481 SHA256 39240c2f354b303894c77ff14a371d4d05cf4425b7e90135fb72d4cf66df0039 SHA512 0672cf1768f46d9eaed2d47ddffbcaee7b8be9172b479aa037747794225286eb19fffa72bf9f4b401fb4e83de4328bab97405d812e9aeea43ea68cc418bb23a0 WHIRLPOOL 3cead50e6cb5cd794652333772249fcfeebb2ff445922268653cf852c4bbc0ad3bd4d629bab3f6e8fb484c574431a277c01543fada73229d9ebbcefd2ca49870
DIST patch-4.12-rc5.patch 90389826 SHA256 b3933852635fc2633bf24357686ea8882c99ab6ea3c8101527a963816aa7b606 SHA512 a5cf9539cd494430933f31d93bc3a952bcb6fca47588c9e4d55957463bd605da667b0f433130e116bf6b09d95e120ea23e8911a51a23b37ef4c4922147b222c8 WHIRLPOOL afbbe0e851d8975488f946b997eea3b987b7fc501cc5722cc40b2789ff4347fdd2824e20e1d193dcf896d19472af430f2e8b5ac38166c2cd51c5b8c8bd606784
+DIST patch-4.12-rc6.patch 90747250 SHA256 b4677b0fc2fa5d9934e41e868981e2a81745b05859cc827e82a97acb5943cd4e SHA512 ac18d248830a5c1cd205c77f1eea0ab50fbb168bccdd3362190c9ba049981b557f614e60aa25bc448c55e2883e12ceab30a1a54bd8c7b0eb09a39925eab26670 WHIRLPOOL ff904bd44669f5e9d20df0cd41fcca4fe901d1a6d6ee6890256640d187307859be53b6c4c753d203d8998e48808ac28d350a2353e5d1665a43ab30f1f62601a3
diff --git a/sys-kernel/git-sources/git-sources-4.12_rc6.ebuild b/sys-kernel/git-sources/git-sources-4.12_rc6.ebuild
new file mode 100644
index 000000000000..77ebfa1611cb
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-4.12_rc6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="4.11"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.4"
+
+pkg_postinst() {
+ postinst_sources
+}