summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-28 19:53:08 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-28 22:43:50 +0200
commitbee4eca120756dd8a40323a60b2fcd93b39bd693 (patch)
tree930ea630a4f69770d8dbb26c2758ecc99fedfc4d /sys-kernel
parentgnome-base/nautilus: Bump to 3.38.2 (diff)
downloadgentoo-bee4eca120756dd8a40323a60b2fcd93b39bd693.tar.gz
gentoo-bee4eca120756dd8a40323a60b2fcd93b39bd693.tar.bz2
gentoo-bee4eca120756dd8a40323a60b2fcd93b39bd693.zip
sys-kernel/vanilla-kernel: Bump to 5.4.115
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/vanilla-kernel/Manifest2
-rw-r--r--sys-kernel/vanilla-kernel/vanilla-kernel-5.4.115.ebuild108
2 files changed, 110 insertions, 0 deletions
diff --git a/sys-kernel/vanilla-kernel/Manifest b/sys-kernel/vanilla-kernel/Manifest
index 857cfe648c46..e5dea7c94fd4 100644
--- a/sys-kernel/vanilla-kernel/Manifest
+++ b/sys-kernel/vanilla-kernel/Manifest
@@ -46,3 +46,5 @@ DIST linux-5.4.113.tar.sign 991 BLAKE2B 3f3d392ecbf345e37aab2be2acabcf1cf39570ff
DIST linux-5.4.113.tar.xz 109091724 BLAKE2B df24da5ec14c0df95c4f350c2bf64ad2bfe66a3ad7a37774b433c847d18efd8029e9054bd1ec969af69d48b1a4bd44d40bb06d3038ff99c423bcc913915b9451 SHA512 a21308478ad83350aa48f316fa94015c56fe79beaca82324c13129812aef12ae1123edd67281b68669e08a827c6923f8cea5598063b31c73a0c901628161d2cd
DIST linux-5.4.114.tar.sign 991 BLAKE2B 8982832ae53b1647e2de45b83251520c6efb5e9ac1ee0b60ba564dc7af3cfb4a328c929998d72dc076eb0528e92cb36222c20b192b003731a2a7b3b0b7c3b62b SHA512 82070ff0fbc730876a93ffce4abac6c349c80c07dcf61bd67fc742c3626f8156295f2e4c648c52a0c7cc81b79ed64daf41b6766394a511662a0c10a5683e00ff
DIST linux-5.4.114.tar.xz 109099616 BLAKE2B ccc84eed56d7379d77f3c211ac35354d31ab15a7455d9fbe9e109ff4f67eeeb2da5d1bad307583ab18d15f3e10ef0e9d24974d5b833d817060cfee537ec5a2e6 SHA512 c22fb1cafb49819c60ed59b411147d7e4513ce41f1b0c31dac46d610a92ee62d7137d9e8654d2330719c42270ff7891edcee987fb4fb1c2b8fbf9c7c428e79d5
+DIST linux-5.4.115.tar.sign 991 BLAKE2B ca965dda28839e3ac3f6a582137257402de9ef3fb825d811c3c86b9d52660bc5e056a7b3bfdc5353b6d24574c9c54ae46e688bf520199349ffeb527ce7246c7b SHA512 b691a972909827c0a97cf8e901e2a36adebac280c0a32f1bac57107ed5d5f1b1b20ee2a5ca08136fd077b9c80d3f72d5084c0623a88362cb1e21f2f72a26c695
+DIST linux-5.4.115.tar.xz 109094472 BLAKE2B c4a8047d8297eae22e0e581f70caba430cc93cdf92a81e0cce12a787248c8d1687bbbb35c3f41808609f6b3f78d491277d9f7daf1910235439b95cd48c5c9233 SHA512 3e2dcdeadb8fb1e67116f04b00c3716686d12a99ee3e48ea3ac9fb1263a36b7b1c01aa837cf0a8409f21392b44abf64e92ed264091b3f5205b75c3b67bb30ffe
diff --git a/sys-kernel/vanilla-kernel/vanilla-kernel-5.4.115.ebuild b/sys-kernel/vanilla-kernel/vanilla-kernel-5.4.115.ebuild
new file mode 100644
index 000000000000..e11e956ef1fd
--- /dev/null
+++ b/sys-kernel/vanilla-kernel/vanilla-kernel-5.4.115.ebuild
@@ -0,0 +1,108 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kernel-build verify-sig
+
+MY_P=linux-${PV}
+# https://koji.fedoraproject.org/koji/packageinfo?packageID=8
+CONFIG_VER=5.4.21
+CONFIG_HASH=2809b7faa6a8cb232cd825096c146b7bdc1e08ea
+GENTOO_CONFIG_VER=5.4.114
+
+DESCRIPTION="Linux kernel built from vanilla upstream sources"
+HOMEPAGE="https://www.kernel.org/"
+SRC_URI+=" https://cdn.kernel.org/pub/linux/kernel/v$(ver_cut 1).x/${MY_P}.tar.xz
+ https://github.com/mgorny/gentoo-kernel-config/archive/v${GENTOO_CONFIG_VER}.tar.gz
+ -> gentoo-kernel-config-${GENTOO_CONFIG_VER}.tar.gz
+ verify-sig? (
+ https://cdn.kernel.org/pub/linux/kernel/v$(ver_cut 1).x/${MY_P}.tar.sign
+ )
+ amd64? (
+ https://src.fedoraproject.org/rpms/kernel/raw/${CONFIG_HASH}/f/kernel-x86_64.config
+ -> kernel-x86_64.config.${CONFIG_VER}
+ )
+ arm64? (
+ https://src.fedoraproject.org/rpms/kernel/raw/${CONFIG_HASH}/f/kernel-aarch64.config
+ -> kernel-aarch64.config.${CONFIG_VER}
+ )
+ ppc64? (
+ https://src.fedoraproject.org/rpms/kernel/raw/${CONFIG_HASH}/f/kernel-ppc64le.config
+ -> kernel-ppc64le.config.${CONFIG_VER}
+ )
+ x86? (
+ https://src.fedoraproject.org/rpms/kernel/raw/${CONFIG_HASH}/f/kernel-i686.config
+ -> kernel-i686.config.${CONFIG_VER}
+ )"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="debug"
+
+RDEPEND="
+ !sys-kernel/vanilla-kernel-bin:${SLOT}"
+BDEPEND="
+ debug? ( dev-util/dwarves )
+ verify-sig? ( app-crypt/openpgp-keys-kernel )"
+PDEPEND="
+ >=virtual/dist-kernel-${PV}"
+
+VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/kernel.org.asc
+
+pkg_pretend() {
+ ewarn "Starting with 5.4.52, Distribution Kernels are switching from Arch"
+ ewarn "Linux configs to Fedora. Please keep a backup kernel just in case."
+
+ kernel-install_pkg_pretend
+}
+
+src_unpack() {
+ if use verify-sig; then
+ einfo "Unpacking linux-${PV}.tar.xz ..."
+ verify-sig_verify_detached - "${DISTDIR}"/linux-${PV}.tar.sign \
+ < <(xz -cd "${DISTDIR}"/linux-${PV}.tar.xz | tee >(tar -x))
+ assert "Unpack failed"
+ unpack "gentoo-kernel-config-${GENTOO_CONFIG_VER}.tar.gz"
+ else
+ default
+ fi
+}
+
+src_prepare() {
+ default
+
+ # prepare the default config
+ case ${ARCH} in
+ amd64)
+ cp "${DISTDIR}/kernel-x86_64.config.${CONFIG_VER}" .config || die
+ ;;
+ arm64)
+ cp "${DISTDIR}/kernel-aarch64.config.${CONFIG_VER}" .config || die
+ ;;
+ ppc64)
+ cp "${DISTDIR}/kernel-ppc64le.config.${CONFIG_VER}" .config || die
+ ;;
+ x86)
+ cp "${DISTDIR}/kernel-i686.config.${CONFIG_VER}" .config || die
+ ;;
+ *)
+ die "Unsupported arch ${ARCH}"
+ ;;
+ esac
+
+ echo 'CONFIG_LOCALVERSION="-dist"' > "${T}"/version.config || die
+ local merge_configs=(
+ "${T}"/version.config
+ "${WORKDIR}/gentoo-kernel-config-${GENTOO_CONFIG_VER}"/base.config
+ )
+ use debug || merge_configs+=(
+ "${WORKDIR}/gentoo-kernel-config-${GENTOO_CONFIG_VER}"/no-debug.config
+ )
+ [[ ${ARCH} == x86 ]] && merge_configs+=(
+ "${WORKDIR}/gentoo-kernel-config-${GENTOO_CONFIG_VER}"/32-bit.config
+ )
+
+ kernel-build_merge_configs "${merge_configs[@]}"
+}