summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2024-02-04 11:02:41 -0500
committerMike Pagano <mpagano@gentoo.org>2024-02-04 11:02:41 -0500
commitf671b1f0b83484caae44d4562ea926f54d3ae476 (patch)
treee46fc99432b64580ef3be14390c226a0b9d2ddbd /sys-kernel
parentdev-python/pip: Add a link to NO_COLOR pull request (diff)
downloadgentoo-f671b1f0b83484caae44d4562ea926f54d3ae476.tar.gz
gentoo-f671b1f0b83484caae44d4562ea926f54d3ae476.tar.bz2
gentoo-f671b1f0b83484caae44d4562ea926f54d3ae476.zip
sys-kernel/git-sources: add 6.8_rc3
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-6.8_rc3.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index 55a389ca9fc2..b0dd8189cd60 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -1,3 +1,4 @@
DIST linux-6.7.tar.xz 141406528 BLAKE2B cecdbd19905e43e485ab73b352ced18b37f2a138c97a6956cadcda5d3d271001117dc1cf896b166ff019fc7f405f9539e2ed0d6112b0890efb04d182adf4fd0e SHA512 de06de556191614bd9daf077ae239360352a402bab407748e67f1e5108c92fd933e451707840ab22fe0f9976db3d1e1b60ca9d41cf894f015ca09b3f652b74ad
DIST patch-6.8-rc1.patch 43389839 BLAKE2B 4aeb6c35ea09960930758160df83ad23caef0f1056c1d134ed0b450802b42619ac44fa0e834a8fb64cf8b1e116be2b179b24d2ccd6620206448e0869590b4a40 SHA512 41ec6a69f635197ea87eccab9415c2072389cedf8dec912c491740bba6507bb97dc7597b80944a0dbe51e88a806c5f3020e4916d418314bb4126bde0ae50ad28
DIST patch-6.8-rc2.patch 43792863 BLAKE2B 7e5c5d3255d79d6318d115948d9994bbf96bd319f20d29ab9554d05ace516f862ef0cc2cb646707cdf91e93f9fd5c93d4263b7251b0b599c6ca0e03ae9ecabda SHA512 1a53a7a47fb146f4bbee0ac9f55bd28a44c0680aaafa78a76215323443e77214790550622a4ec4b338a1dabe6552e5688c68b3592ac313b409794a86fd70c64c
+DIST patch-6.8-rc3.patch 44394710 BLAKE2B 626c9569dbc8ff077f5dedd8cf01553f0f9261b28407eaa08c4cf502aaf529441bea97c2c6ae1c01654a9b78feb77be32168a4dd082643b079b1c6379222f70e SHA512 255c0700bb24a3aea781c40a96e48a28583f6266940b4127af93e893361fa7e9a9ab5fdd435648de56d9c18bf06ce5a73cd8013a3c3f20c55f470fdeeca4e6b0
diff --git a/sys-kernel/git-sources/git-sources-6.8_rc3.ebuild b/sys-kernel/git-sources/git-sources-6.8_rc3.ebuild
new file mode 100644
index 000000000000..ca760a458b08
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-6.8_rc3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="6.7"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+K_NODRYRUN="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.6-r4"
+
+pkg_postinst() {
+ postinst_sources
+}