summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2021-10-04 15:26:58 -0400
committerMike Pagano <mpagano@gentoo.org>2021-10-04 15:26:58 -0400
commitf878c2b0c29401feb55bf1e16be5b2538e7f3845 (patch)
tree19db4641b90136f8082356e7a0892e352509ff55 /sys-kernel
parentsci-libs/amd: Stabilize 2.4.6-r1 ppc, #816234 (diff)
downloadgentoo-f878c2b0c29401feb55bf1e16be5b2538e7f3845.tar.gz
gentoo-f878c2b0c29401feb55bf1e16be5b2538e7f3845.tar.bz2
gentoo-f878c2b0c29401feb55bf1e16be5b2538e7f3845.zip
sys-kernel/git-sources: Linux patch 5.15-rc4
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-5.15_rc4.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index 889564747615..77dc550d0cc9 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -2,3 +2,4 @@ DIST linux-5.14.tar.xz 120669872 BLAKE2B 0047f5aaa3940dff97f4055ef544faafbbb5282
DIST patch-5.15-rc1.patch 41357462 BLAKE2B 7df3298b6dcf7eb5a4867e84dc801e344063645f12af695fd81cc8310dd6fe79da06412e893eefa220d45c0118de6f5ae1768bc009cdb1b37d9fc0bb4fdb919a SHA512 d045bb66c810b2fe2c700cbd4518a1329fdf006402e382bfcf0f097785409d00187df1fc998944abb46e5eaa6884cd5b50d20575adb4e77342ce11c951cf6317
DIST patch-5.15-rc2.patch 41617220 BLAKE2B b2216f798e64ccbcd3d6a9ecbf77388a6af97bce43c913dc0b8561db909b15f242ea63a5a266c422f887ef5f1232119f30b213fa9604a57596611f69b51964e9 SHA512 76d1054282c00adef7c31701e0991e9d279e641ee4f009713169aea2f0c9e4cce0eca356e32ed8e818fef57b601f9205f2ff32e4a139bb2ac48a2bd1d2b4a178
DIST patch-5.15-rc3.patch 41945558 BLAKE2B 550064d9cd8b30c062cd4411d169547317a406e259cc46b124a8e6115d2ff4e370903fad3a5bf4e62e9db07fb7d510ecf6c2b36ba27534b813cb379f7fe9c966 SHA512 6e3ae62519dd991d26eee5063d511749d282ad1b8a57d020ee179a5819ed7842f3f22c2ac8ec972f57bb1d4650f46ee3d8a98f52d33c7e82412e4968af2ed3cc
+DIST patch-5.15-rc4.patch 42309515 BLAKE2B bb92e0f0fe290faf86da6f0cb4980b1af700d735bb22250851df5c6712af59b82de524cd96f9e3180c4d77121d09258109c16fb48d342e6117073d2ac8189524 SHA512 e5b3c895d72d7c9be5ce409072a3076d5c9789a510e72cd6e5c79011a321a1de219bd84e6ce3df5cba94f4103dbb3c8082e0317b7783138dba05b956737e697c
diff --git a/sys-kernel/git-sources/git-sources-5.15_rc4.ebuild b/sys-kernel/git-sources/git-sources-5.15_rc4.ebuild
new file mode 100644
index 000000000000..d7e4ec9a1508
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-5.15_rc4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="5.14"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.5"
+
+pkg_postinst() {
+ postinst_sources
+}