summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2017-01-16 10:39:08 +0100
committerAgostino Sarubbo <ago@gentoo.org>2017-01-16 10:39:08 +0100
commitf983f24190be5172591c364d0975c584ea943d5b (patch)
treec4ce601fba68892f322757e10ec95a3cbfec85d7 /sys-kernel
parentdev-python/flask-bootstrap: bump to 3.3.7.1 (diff)
downloadgentoo-f983f24190be5172591c364d0975c584ea943d5b.tar.gz
gentoo-f983f24190be5172591c364d0975c584ea943d5b.tar.bz2
gentoo-f983f24190be5172591c364d0975c584ea943d5b.zip
sys-kernel/git-sources: Automated version bump to 4.10_rc4
Package-Manager: portage-2.3.0 Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-4.10_rc4.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index 11fb0a005b02..0bb2253494ce 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -2,3 +2,4 @@ DIST linux-4.9.tar.xz 93192404 SHA256 029098dcffab74875e086ae970e3828456838da6e0
DIST patch-4.10-rc1.xz 7387972 SHA256 6b269bd7bf6a13733269f89b1205db7f76434dc9aa96cc5a1537decc5d2f5053 SHA512 1ea3cb9e808c8ad0ca28bf430c5ed1e6b8039f195b1ebe42429bddad0b0afcf1a1a619cb20eb0da614f2180cc94e9658a94d45432f8a4d402a955c7f0b0c5289 WHIRLPOOL 8cc1ddc34fc1644831e1d55d40099c2651f3bc38e2ebb64ec3476e2e5963c57513912e2455a2ef763390a9aa17e64557b4a92472218f49bb7583a465441c18cd
DIST patch-4.10-rc2.xz 7392684 SHA256 358f373a71caabb9597bfe1b3f3fb9a8e71d303d5eca2a6d6534167141290a99 SHA512 45ec25c586aa89e4e8dd53cf01a88e25331e379a2532a7059eb182a634279c92e23d057c71df10ceb374fcc51c3a4eed6769261a7e2b9c5cd0112a81161ff597 WHIRLPOOL 41f2f4453b1a16390b2819500dc1ec36f3a7c6993a753dc420cea21b1466e3ce536a08ad580aaafe986827e407bc2503337e6e967549f1044cf4a93693a8837e
DIST patch-4.10-rc3.xz 7431972 SHA256 cc5f910e05edbc4b4cd16beca39274d49c96954d09447101bd477725158b49eb SHA512 3573b198b6ee488d6c573dd09c534548a08bcf8a017a94f74d127a58a018c9e97056006fccd555aa49513cc3f98ad5c1cb6545a7e261d3ccaea21456b53f2dd5 WHIRLPOOL 80a1316f9a7399f079e99ac8ed7f6e0cc0a014942b2ad108714c5b07291266343e1b8e960267dd9888305f0220cf41d03dca3d7fede622ce381820678d85b367
+DIST patch-4.10-rc4.xz 7486192 SHA256 95b8a31b423d4eb33af0963de41a1a657baf8f06ebfa02bcffd14c4dc3b1a167 SHA512 89d903d52ff907f3911ac09214d1299c310fd67b7ff36170c6233e6348049fb0f669ba245a8ca310f52c91eb523aa5f91a9b52f4c67ca932b951fe2c60f25ae5 WHIRLPOOL 8afec9c31a88a335b9c6d63e02ab5ce6cf05c14b1edaedbe5aa9dd00b5d2e3e878bf31c8c67f10dcfda85c2e9183abea2e8ebdaa2ce2d024371df2c59ee10b36
diff --git a/sys-kernel/git-sources/git-sources-4.10_rc4.ebuild b/sys-kernel/git-sources/git-sources-4.10_rc4.ebuild
new file mode 100644
index 000000000000..05f9017871b5
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-4.10_rc4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="4.9"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.4"
+
+pkg_postinst() {
+ postinst_sources
+}