summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-02-19 18:54:02 +0100
committerMichał Górny <mgorny@gentoo.org>2018-02-19 18:55:24 +0100
commita696cac905cc854b61b5c91515c48f7e1b476ed9 (patch)
tree524a862709be0e097ff4cf5b81abb6faa6c7e4f9 /sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-9999.ebuild
parentmetadata/layout.conf: Update manifest-required-hashes to BLAKE2B (diff)
downloadgentoo-a696cac905cc854b61b5c91515c48f7e1b476ed9.tar.gz
gentoo-a696cac905cc854b61b5c91515c48f7e1b476ed9.tar.bz2
gentoo-a696cac905cc854b61b5c91515c48f7e1b476ed9.zip
sys-libs/compiler-rt-sanitizers: Stop using unsandbox in 6.0+
Stop relying on app-portage/unsandbox in the live ebuilds. Instead, rely on sys-apps/sandbox-2.13 that supports stopping to clobber LD_PRELOAD on its own!
Diffstat (limited to 'sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-9999.ebuild')
-rw-r--r--sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-9999.ebuild13
1 files changed, 6 insertions, 7 deletions
diff --git a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-9999.ebuild b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-9999.ebuild
index 2b85804e799d..f83cb210e4e7 100644
--- a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-9999.ebuild
+++ b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-9999.ebuild
@@ -29,7 +29,7 @@ DEPEND="
>=sys-devel/llvm-6
clang? ( sys-devel/clang )
test? (
- app-portage/unsandbox
+ !<sys-apps/sandbox-2.13
$(python_gen_any_dep "~dev-python/lit-${PV}[\${PYTHON_USEDEP}]")
=sys-devel/clang-${PV%_*}*:${LLVM_SLOT}
sys-libs/compiler-rt:${SLOT} )
@@ -95,14 +95,9 @@ src_configure() {
-DCOMPILER_RT_BUILD_XRAY=ON
)
if use test; then
- cat > "${T}"/unsandbox-lit.py <<-EOF || die
- import os, sys
- os.execlp("unsandbox", sys.argv[0], "lit", *sys.argv[1:])
- EOF
-
mycmakeargs+=(
-DLLVM_MAIN_SRC_DIR="${WORKDIR}/llvm"
- -DLLVM_EXTERNAL_LIT="${T}/unsandbox-lit.py"
+ -DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"
-DLLVM_LIT_ARGS="-vv"
# they are created during src_test()
@@ -151,6 +146,10 @@ src_configure() {
src_test() {
# respect TMPDIR!
local -x LIT_PRESERVES_TMP=1
+ # disable sandbox to have it stop clobbering LD_PRELOAD
+ local -x SANDBOX_ON=0
+ # wipe LD_PRELOAD to make ASAN happy
+ local -x LD_PRELOAD=
cmake-utils_src_make check-all
}