summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-13 11:12:10 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-13 11:12:10 +0100
commit61913dcd170a0c5b56725f94b6985cca376987ba (patch)
tree7738af308a3726bb2d43c48811c69db1cbe4ef92 /sys-libs/compiler-rt/compiler-rt-15.0.7.ebuild
parentdev-debug/lldb: Remove redundant cmake dep (diff)
downloadgentoo-61913dcd170a0c5b56725f94b6985cca376987ba.tar.gz
gentoo-61913dcd170a0c5b56725f94b6985cca376987ba.tar.bz2
gentoo-61913dcd170a0c5b56725f94b6985cca376987ba.zip
sys-libs/compiler-rt: Remove redundant cmake dep
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-libs/compiler-rt/compiler-rt-15.0.7.ebuild')
-rw-r--r--sys-libs/compiler-rt/compiler-rt-15.0.7.ebuild5
1 files changed, 2 insertions, 3 deletions
diff --git a/sys-libs/compiler-rt/compiler-rt-15.0.7.ebuild b/sys-libs/compiler-rt/compiler-rt-15.0.7.ebuild
index 32f758f51aa5..c979daaf6e68 100644
--- a/sys-libs/compiler-rt/compiler-rt-15.0.7.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-15.0.7.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit cmake flag-o-matic llvm llvm.org python-any-r1 toolchain-funcs
DESCRIPTION="Compiler runtime library for clang (built-in part)"
@@ -19,7 +19,6 @@ DEPEND="
sys-devel/llvm:${LLVM_MAJOR}
"
BDEPEND="
- >=dev-util/cmake-3.16
clang? ( sys-devel/clang )
test? (
$(python_gen_any_dep ">=dev-python/lit-15[\${PYTHON_USEDEP}]")