summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-03-23 10:32:04 +0100
committerMichał Górny <mgorny@gentoo.org>2018-03-23 10:35:54 +0100
commit682b9c2a05fd86ba79a916d151c3029ecb779d92 (patch)
treee0fbd03ea3631f3f68dc5c2282cd44eb180484bf /sys-libs/compiler-rt/compiler-rt-6.0.9999.ebuild
parentsys-devel/llvm: Apply -fno-bmi only on x86 arches (diff)
downloadgentoo-682b9c2a05fd86ba79a916d151c3029ecb779d92.tar.gz
gentoo-682b9c2a05fd86ba79a916d151c3029ecb779d92.tar.bz2
gentoo-682b9c2a05fd86ba79a916d151c3029ecb779d92.zip
sys-libs/compiler-rt: Fix LLVM_MAX_SLOT -> CLANG_SLOT
The variable was intentionally chosen not to use the eclass, and its my mistake of conflating the two. Name it CLANG_SLOT to make it look more purposeful. Closes: https://bugs.gentoo.org/650750 Fixes: ade5b255f1e8 (sys-libs/compiler-rt: fix eclass use by LLVM_SLOT...)
Diffstat (limited to 'sys-libs/compiler-rt/compiler-rt-6.0.9999.ebuild')
-rw-r--r--sys-libs/compiler-rt/compiler-rt-6.0.9999.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/sys-libs/compiler-rt/compiler-rt-6.0.9999.ebuild b/sys-libs/compiler-rt/compiler-rt-6.0.9999.ebuild
index 2542708841ae..74f0dac70c66 100644
--- a/sys-libs/compiler-rt/compiler-rt-6.0.9999.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-6.0.9999.ebuild
@@ -25,14 +25,14 @@ KEYWORDS=""
IUSE="+clang test"
RESTRICT="!test? ( test ) !clang? ( test )"
-LLVM_MAX_SLOT=${SLOT%%.*}
+CLANG_SLOT=${SLOT%%.*}
# llvm-6 for new lit options
DEPEND="
>=sys-devel/llvm-6
clang? ( sys-devel/clang )
test? (
$(python_gen_any_dep "dev-python/lit[\${PYTHON_USEDEP}]")
- =sys-devel/clang-${PV%_*}*:${LLVM_MAX_SLOT} )
+ =sys-devel/clang-${PV%_*}*:${CLANG_SLOT} )
${PYTHON_DEPS}"
# least intrusive of all
@@ -95,8 +95,8 @@ src_configure() {
-DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"
-DLLVM_LIT_ARGS="-vv;-j;${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}"
- -DCOMPILER_RT_TEST_COMPILER="${EPREFIX}/usr/lib/llvm/${LLVM_MAX_SLOT}/bin/clang"
- -DCOMPILER_RT_TEST_CXX_COMPILER="${EPREFIX}/usr/lib/llvm/${LLVM_MAX_SLOT}/bin/clang++"
+ -DCOMPILER_RT_TEST_COMPILER="${EPREFIX}/usr/lib/llvm/${CLANG_SLOT}/bin/clang"
+ -DCOMPILER_RT_TEST_CXX_COMPILER="${EPREFIX}/usr/lib/llvm/${CLANG_SLOT}/bin/clang++"
)
fi