summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-02 13:47:51 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-03 08:04:05 +0200
commit582b7d154fe6d89a7c9901b5d0a89d0db0170f2c (patch)
tree0c3d96aba02f54736cc00cbee99ddff542419e5d /sys-libs/compiler-rt
parentdev-util/lldb: Ensure NDEBUG correctly (diff)
downloadgentoo-582b7d154fe6d89a7c9901b5d0a89d0db0170f2c.tar.gz
gentoo-582b7d154fe6d89a7c9901b5d0a89d0db0170f2c.tar.bz2
gentoo-582b7d154fe6d89a7c9901b5d0a89d0db0170f2c.zip
sys-libs/compiler-rt: Ensure NDEBUG correctly
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-libs/compiler-rt')
-rw-r--r--sys-libs/compiler-rt/compiler-rt-13.0.0.9999.ebuild5
-rw-r--r--sys-libs/compiler-rt/compiler-rt-13.0.0.ebuild5
-rw-r--r--sys-libs/compiler-rt/compiler-rt-14.0.0.9999.ebuild5
3 files changed, 12 insertions, 3 deletions
diff --git a/sys-libs/compiler-rt/compiler-rt-13.0.0.9999.ebuild b/sys-libs/compiler-rt/compiler-rt-13.0.0.9999.ebuild
index f726db78861b..d6a1a16eb346 100644
--- a/sys-libs/compiler-rt/compiler-rt-13.0.0.9999.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-13.0.0.9999.ebuild
@@ -12,7 +12,7 @@ HOMEPAGE="https://llvm.org/"
LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
SLOT="$(ver_cut 1-3)"
KEYWORDS=""
-IUSE="+clang test"
+IUSE="+clang debug test"
RESTRICT="!test? ( test ) !clang? ( test )"
CLANG_SLOT=${SLOT%%.*}
@@ -60,6 +60,9 @@ test_compiler() {
}
src_configure() {
+ # LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
+ use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"
+
# pre-set since we need to pass it to cmake
BUILD_DIR=${WORKDIR}/${P}_build
diff --git a/sys-libs/compiler-rt/compiler-rt-13.0.0.ebuild b/sys-libs/compiler-rt/compiler-rt-13.0.0.ebuild
index a3954df9f7dc..92894146cb09 100644
--- a/sys-libs/compiler-rt/compiler-rt-13.0.0.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-13.0.0.ebuild
@@ -12,7 +12,7 @@ HOMEPAGE="https://llvm.org/"
LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
SLOT="$(ver_cut 1-3)"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~ppc-macos ~x64-macos"
-IUSE="+clang test"
+IUSE="+clang debug test"
RESTRICT="!test? ( test ) !clang? ( test )"
CLANG_SLOT=${SLOT%%.*}
@@ -60,6 +60,9 @@ test_compiler() {
}
src_configure() {
+ # LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
+ use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"
+
# pre-set since we need to pass it to cmake
BUILD_DIR=${WORKDIR}/${P}_build
diff --git a/sys-libs/compiler-rt/compiler-rt-14.0.0.9999.ebuild b/sys-libs/compiler-rt/compiler-rt-14.0.0.9999.ebuild
index f726db78861b..d6a1a16eb346 100644
--- a/sys-libs/compiler-rt/compiler-rt-14.0.0.9999.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-14.0.0.9999.ebuild
@@ -12,7 +12,7 @@ HOMEPAGE="https://llvm.org/"
LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
SLOT="$(ver_cut 1-3)"
KEYWORDS=""
-IUSE="+clang test"
+IUSE="+clang debug test"
RESTRICT="!test? ( test ) !clang? ( test )"
CLANG_SLOT=${SLOT%%.*}
@@ -60,6 +60,9 @@ test_compiler() {
}
src_configure() {
+ # LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
+ use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"
+
# pre-set since we need to pass it to cmake
BUILD_DIR=${WORKDIR}/${P}_build