summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-01-15 15:00:25 +0100
committerMichał Górny <mgorny@gentoo.org>2017-01-15 15:30:58 +0100
commitbc308c000d707403d8801c77b20dc931902018a2 (patch)
tree27db827bcf149c7f7d2a2bac474746b992a788c3 /sys-libs/compiler-rt
parentsys-devel/lld: Remove unnecessary LLVM_LIBDIR_SUFFIX (diff)
downloadgentoo-bc308c000d707403d8801c77b20dc931902018a2.tar.gz
gentoo-bc308c000d707403d8801c77b20dc931902018a2.tar.bz2
gentoo-bc308c000d707403d8801c77b20dc931902018a2.zip
sys-libs/compiler-rt: Remove unnecessary LLVM_LIBDIR_SUFFIX
Diffstat (limited to 'sys-libs/compiler-rt')
-rw-r--r--sys-libs/compiler-rt/compiler-rt-9999.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/sys-libs/compiler-rt/compiler-rt-9999.ebuild b/sys-libs/compiler-rt/compiler-rt-9999.ebuild
index fd1f907da74d..4f6d080ee475 100644
--- a/sys-libs/compiler-rt/compiler-rt-9999.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-9999.ebuild
@@ -24,9 +24,10 @@ KEYWORDS=""
IUSE="test"
RDEPEND="
- !<sys-devel/llvm-4.0"
+ !<sys-devel/llvm-4"
+# llvm-4 needed for --cmakedir
DEPEND="${RDEPEND}
- ~sys-devel/llvm-${PV}
+ >=sys-devel/llvm-4
test? ( ~sys-devel/clang-${PV} )
${PYTHON_DEPS}"
@@ -54,8 +55,6 @@ src_configure() {
local clang_version=$(get_version_component_range 1-3 "${llvm_version}")
local libdir=$(get_libdir)
local mycmakeargs=(
- # used to find cmake modules
- -DLLVM_LIBDIR_SUFFIX="${libdir#lib}"
-DCOMPILER_RT_INSTALL_PATH="${EPREFIX}/usr/lib/clang/${clang_version}"
# use a build dir structure consistent with install
# this makes it possible to easily deploy test-friendly clang