summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Haubenwallner <haubi@gentoo.org>2017-01-16 15:14:53 +0100
committerMichael Haubenwallner <haubi@gentoo.org>2017-01-16 15:17:11 +0100
commitc8e5a7b3427a5b30841082958e67980e7a3bb01c (patch)
tree766a309e1aad36fa394300f9057b33b625eb7b77 /sys-libs/cygwin-crypt/cygwin-crypt-1.4.ebuild
parentkde-apps/thumbnailers: Set KDE_BLOCK_SLOT4=false (diff)
downloadgentoo-c8e5a7b3427a5b30841082958e67980e7a3bb01c.tar.gz
gentoo-c8e5a7b3427a5b30841082958e67980e7a3bb01c.tar.bz2
gentoo-c8e5a7b3427a5b30841082958e67980e7a3bb01c.zip
sys-libs/cygwin-crypt: initial commit, v1.4
Package-Manager: portage-2.2.28
Diffstat (limited to 'sys-libs/cygwin-crypt/cygwin-crypt-1.4.ebuild')
-rw-r--r--sys-libs/cygwin-crypt/cygwin-crypt-1.4.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sys-libs/cygwin-crypt/cygwin-crypt-1.4.ebuild b/sys-libs/cygwin-crypt/cygwin-crypt-1.4.ebuild
new file mode 100644
index 000000000000..6148353483b6
--- /dev/null
+++ b/sys-libs/cygwin-crypt/cygwin-crypt-1.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Cygwin Encryption/Decryption utility and library"
+HOMEPAGE="https://sourceware.org/cygwin-apps/"
+# Upstream provides the git repo only, so we do:
+# git clone git://cygwin.com/git/cygwin-apps/crypt.git
+# cd crypt
+# git archive -o cygwin-crypt-${PV}.tar --prefix=cygwin-crypt-${PV}/ crypt-${PV}-release
+# bzip2 cygwin-crypt-${PV}.tar
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~x64-cygwin ~x86-cygwin"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+mymake() {
+ emake \
+ CC="$(tc-getCC)" \
+ AR="$(tc-getAR)" \
+ CFLAGS="${CFLAGS}" \
+ prefix="${EPREFIX}/usr" \
+ docdir="${EPREFIX}/share/doc/${P}" \
+ "$@"
+}
+
+src_compile() {
+ mymake
+}
+
+src_install() {
+ mymake install DESTDIR="${D}"
+}