summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatoro Mahri <matoro_gentoo@matoro.tk>2024-04-25 23:48:40 -0400
committerSam James <sam@gentoo.org>2024-04-30 06:52:49 +0100
commitcda927fb0d36cdb0563413cc92818dcf358dd0df (patch)
treeabc093fdb1725d9a68e488386657f798f65382fc /sys-libs/glibc/glibc-2.38-r12.ebuild
parentprofiles/arch/x86: stable-mask app-emulation/libvirt[nbd] (diff)
downloadgentoo-cda927fb0d36cdb0563413cc92818dcf358dd0df.tar.gz
gentoo-cda927fb0d36cdb0563413cc92818dcf358dd0df.tar.bz2
gentoo-cda927fb0d36cdb0563413cc92818dcf358dd0df.zip
sys-libs/glibc: skip tst-nice with nice 19
Fails otherwise, because it expects to see a change when bumping niceness, but no change can be make when niceness is already at max. Bug: https://bugs.gentoo.org/927238 Signed-off-by: Matoro Mahri <matoro_gentoo@matoro.tk> Closes: https://github.com/gentoo/gentoo/pull/36429 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-libs/glibc/glibc-2.38-r12.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.38-r12.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/sys-libs/glibc/glibc-2.38-r12.ebuild b/sys-libs/glibc/glibc-2.38-r12.ebuild
index 9c1814df87de..3faaa1af693c 100644
--- a/sys-libs/glibc/glibc-2.38-r12.ebuild
+++ b/sys-libs/glibc/glibc-2.38-r12.ebuild
@@ -1272,6 +1272,11 @@ glibc_src_test() {
ewarn "Skipping extra tests because in systemd-nspawn container"
XFAIL_TEST_LIST+=( "${XFAIL_NSPAWN_TEST_LIST[@]}" )
fi
+ if [[ "$(nice)" == "19" ]] ; then
+ # Expects to be able to increase niceness, which it can't do if
+ # already at the highest nice value
+ XFAIL_TEST_LIST+=( "tst-nice" )
+ fi
for myt in ${XFAIL_TEST_LIST[@]} ; do
myxfailparams+="test-xfail-${myt}=yes "