summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-11-03 00:53:29 +0000
committerSam James <sam@gentoo.org>2021-11-03 00:54:12 +0000
commit3062f2ce92ef51f40385300dc9d3a3ec176bb9c6 (patch)
treef72e4d11e3b3c8cb0cc3da8eac78bb7a84b18dc8 /sys-libs/glibc/glibc-9999.ebuild
parentsys-apps/sandbox: version bump to 3.0 (diff)
downloadgentoo-3062f2ce92ef51f40385300dc9d3a3ec176bb9c6.tar.gz
gentoo-3062f2ce92ef51f40385300dc9d3a3ec176bb9c6.tar.bz2
gentoo-3062f2ce92ef51f40385300dc9d3a3ec176bb9c6.zip
sys-libs/glibc: only copy crypt.h if it exists
Some folks may have rather strict INSTALL_MASKs and such and don't need headers, so if they don't have it already, go with it. Bug: https://bugs.gentoo.org/802207 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-libs/glibc/glibc-9999.ebuild')
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild15
1 files changed, 13 insertions, 2 deletions
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index 7be3669c52a0..ce817f25421f 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -1519,7 +1519,12 @@ pkg_preinst() {
if ! use crypt && has_version "${CATEGORY}/${PN}[crypt]"; then
PRESERVED_OLD_LIBCRYPT=1
preserve_old_lib /$(get_libdir)/libcrypt$(get_libname 1)
- cp "${EROOT}"/usr/include/crypt.h "${T}"/crypt.h || die
+
+ # Only copy if it exists; some people may have tiny embedded
+ # systems without headers: https://bugs.gentoo.org/802207#c16
+ if [[ -f "${EROOT}"/usr/include/crypt.h ]] ; then
+ cp "${EROOT}"/usr/include/crypt.h "${T}"/crypt.h || die
+ fi
else
PRESERVED_OLD_LIBCRYPT=0
fi
@@ -1555,7 +1560,13 @@ pkg_postinst() {
if [[ ${PRESERVED_OLD_LIBCRYPT} -eq 1 ]] ; then
preserve_old_lib_notify /$(get_libdir)/libcrypt$(get_libname 1)
- cp "${T}"/crypt.h "${EROOT}"/usr/include/crypt.h || eerror "Error restoring crypt.h, please file a bug"
+
+ # Only copy if it exists; some people may have tiny embedded
+ # systems without headers: https://bugs.gentoo.org/802207#c16
+ if [[ -f "${T}"/crypt.h ]] ; then
+ cp "${T}"/crypt.h "${EROOT}"/usr/include/crypt.h || eerror "Error restoring crypt.h, please file a bug"
+ fi
+
elog "Please ignore a possible later error message about a file collision involving"
elog "/usr/include/crypt.h. We need to preserve this file for the moment to keep"
elog "the upgrade working, but it also needs to be overwritten when"