summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-04-02 08:01:38 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-04-02 08:03:31 +0100
commit09dbbf679f35d0cce0b1f453e5a4efbcb99872bb (patch)
treed465650fe93266b91d399bb3263abcc2007d2d0b /sys-libs/glibc
parentsys-libs/libunwind: When USE="lzma", depend on app-arch/xz-utils[static-libs?]. (diff)
downloadgentoo-09dbbf679f35d0cce0b1f453e5a4efbcb99872bb.tar.gz
gentoo-09dbbf679f35d0cce0b1f453e5a4efbcb99872bb.tar.bz2
gentoo-09dbbf679f35d0cce0b1f453e5a4efbcb99872bb.zip
sys-libs/glibc: set correct cross-CC for sparc32
Commit "sys-libs/glibc: Drop SPARC CHOST mangling" exposed a old bug where we were setting CC=${CTARGET_OPT}. But we don't have ${CTARGET_OPT}-gcc or anything else and thus fallback to 'gcc' happens. Always use CC=${CTARGET}. Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-libs/glibc')
-rw-r--r--sys-libs/glibc/glibc-2.29-r7.ebuild2
-rw-r--r--sys-libs/glibc/glibc-2.30-r6.ebuild2
-rw-r--r--sys-libs/glibc/glibc-2.31-r2.ebuild2
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild2
4 files changed, 4 insertions, 4 deletions
diff --git a/sys-libs/glibc/glibc-2.29-r7.ebuild b/sys-libs/glibc/glibc-2.29-r7.ebuild
index 1ffe9800d1dc..6492f3e4beec 100644
--- a/sys-libs/glibc/glibc-2.29-r7.ebuild
+++ b/sys-libs/glibc/glibc-2.29-r7.ebuild
@@ -446,7 +446,7 @@ setup_env() {
# configure script checks CFLAGS for some targets (like mips). Keep
# around the original clean value to avoid appending multiple ABIs on
# top of each other.
- : ${__GLIBC_CC:=$(tc-getCC ${CTARGET_OPT:-${CTARGET}})}
+ : ${__GLIBC_CC:=$(tc-getCC ${CTARGET})}
export __GLIBC_CC CC="${__GLIBC_CC} ${!VAR}"
einfo " $(printf '%15s' 'Manual CC:') ${CC}"
}
diff --git a/sys-libs/glibc/glibc-2.30-r6.ebuild b/sys-libs/glibc/glibc-2.30-r6.ebuild
index 00846478a13e..779353d0f841 100644
--- a/sys-libs/glibc/glibc-2.30-r6.ebuild
+++ b/sys-libs/glibc/glibc-2.30-r6.ebuild
@@ -472,7 +472,7 @@ setup_env() {
# configure script checks CFLAGS for some targets (like mips). Keep
# around the original clean value to avoid appending multiple ABIs on
# top of each other.
- : ${__GLIBC_CC:=$(tc-getCC ${CTARGET_OPT:-${CTARGET}})}
+ : ${__GLIBC_CC:=$(tc-getCC ${CTARGET})}
export __GLIBC_CC CC="${__GLIBC_CC} ${!VAR}"
einfo " $(printf '%15s' 'Manual CC:') ${CC}"
}
diff --git a/sys-libs/glibc/glibc-2.31-r2.ebuild b/sys-libs/glibc/glibc-2.31-r2.ebuild
index a46143ef0a5d..db866fbf1a24 100644
--- a/sys-libs/glibc/glibc-2.31-r2.ebuild
+++ b/sys-libs/glibc/glibc-2.31-r2.ebuild
@@ -463,7 +463,7 @@ setup_env() {
# configure script checks CFLAGS for some targets (like mips). Keep
# around the original clean value to avoid appending multiple ABIs on
# top of each other.
- : ${__GLIBC_CC:=$(tc-getCC ${CTARGET_OPT:-${CTARGET}})}
+ : ${__GLIBC_CC:=$(tc-getCC ${CTARGET})}
export __GLIBC_CC CC="${__GLIBC_CC} ${!VAR}"
einfo " $(printf '%15s' 'Manual CC:') ${CC}"
}
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index 38268c5f9372..ca7219535589 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -462,7 +462,7 @@ setup_env() {
# configure script checks CFLAGS for some targets (like mips). Keep
# around the original clean value to avoid appending multiple ABIs on
# top of each other.
- : ${__GLIBC_CC:=$(tc-getCC ${CTARGET_OPT:-${CTARGET}})}
+ : ${__GLIBC_CC:=$(tc-getCC ${CTARGET})}
export __GLIBC_CC CC="${__GLIBC_CC} ${!VAR}"
einfo " $(printf '%15s' 'Manual CC:') ${CC}"
}