summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-07-22 21:58:25 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-07-22 22:00:03 +0200
commit63b750feadcbe282992ae70902c3174394ee9229 (patch)
tree82476f2df6456b0731d65bbded6bff229ea3bbc9 /sys-libs/glibc
parentdev-util/oprofile: ppc64 stable #787713 (diff)
downloadgentoo-63b750feadcbe282992ae70902c3174394ee9229.tar.gz
gentoo-63b750feadcbe282992ae70902c3174394ee9229.tar.bz2
gentoo-63b750feadcbe282992ae70902c3174394ee9229.zip
sys-libs/glibc: Fix last-minute run tests
Upstream now only installs canonical names for shared objects, which means there is no /lib*/ld*.so anymore ... Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'sys-libs/glibc')
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index b3fc7c71c7b2..f4d9edbe46d2 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -1448,6 +1448,12 @@ glibc_sanity_check() {
# (e.g. /var/tmp/portage:${HOSTNAME})
pushd "${ED}"/$(get_libdir) >/dev/null
+ # first let's find the actual dynamic linker here
+ # symlinks may point to the wrong abi
+ local newldso=$(find . -name 'ld-linux*.so.2' -type f -print -quit)
+
+ einfo Last-minute run tests with ${newldso} in /$(get_libdir) ...
+
local x striptest
for x in cal date env free ls true uname uptime ; do
x=$(type -p ${x})
@@ -1460,7 +1466,7 @@ glibc_sanity_check() {
# We need to clear the locale settings as the upgrade might want
# incompatible locale data. This test is not for verifying that.
LC_ALL=C \
- ./ld-*.so --library-path . ${x} > /dev/null \
+ ${newldso} --library-path . ${x} > /dev/null \
|| die "simple run test (${x}) failed"
done