summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2018-04-09 23:36:03 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2018-04-09 23:37:58 +0100
commit9e49c5ca961aa85703fbe41c84e108d212fd2a2b (patch)
tree73cf9313bf889a7ada74c103374720f600ece209 /sys-libs/glibc
parentapp-shells/hstr: clean duplicate patches. (diff)
downloadgentoo-9e49c5ca961aa85703fbe41c84e108d212fd2a2b.tar.gz
gentoo-9e49c5ca961aa85703fbe41c84e108d212fd2a2b.tar.bz2
gentoo-9e49c5ca961aa85703fbe41c84e108d212fd2a2b.zip
sys-libs/glibc: fix strip path for cross-compiler's glibc
Noticed as warnings on non-existing path when installing =cross-powerpc64le-foo-linux-gnu/glibc-2.27-r1 Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'sys-libs/glibc')
-rw-r--r--sys-libs/glibc/glibc-2.27-r1.ebuild2
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild2
2 files changed, 2 insertions, 2 deletions
diff --git a/sys-libs/glibc/glibc-2.27-r1.ebuild b/sys-libs/glibc/glibc-2.27-r1.ebuild
index 523de8fcfa8d..017249c804fe 100644
--- a/sys-libs/glibc/glibc-2.27-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.27-r1.ebuild
@@ -1324,7 +1324,7 @@ src_strip() {
# if user has stripping enabled and does not have split debug turned on,
# then leave the debugging sections in libpthread.
if ! has nostrip ${FEATURES} && ! has splitdebug ${FEATURES} ; then
- ${STRIP:-${CTARGET}-strip} --strip-debug "${ED}"/*/libpthread-*.so
+ ${STRIP:-${CTARGET}-strip} --strip-debug "${ED}"$(alt_prefix)/*/libpthread-*.so
fi
}
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index 24e9f43bde8f..100724cc8416 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -1324,7 +1324,7 @@ src_strip() {
# if user has stripping enabled and does not have split debug turned on,
# then leave the debugging sections in libpthread.
if ! has nostrip ${FEATURES} && ! has splitdebug ${FEATURES} ; then
- ${STRIP:-${CTARGET}-strip} --strip-debug "${ED}"/*/libpthread-*.so
+ ${STRIP:-${CTARGET}-strip} --strip-debug "${ED}"$(alt_prefix)/*/libpthread-*.so
fi
}